Access Khadas VIM through old PC with Lubuntu using Kermit


#1

Hi,

In order to adjust the video configuration of Ubuntu in my Khadas Vim(installed with Nougat) I’m trying to connect it through serial port (pins 17,18,19) as instructed in the doc on debugging interface. I made a USB cable as instructed in that documentation and I installed the Kermitc in my Lubuntu. In the /etc/kermit/kermrc I add the following:

set line /dev/ttyUSB0
set speed 115200
set carrier-watch off
set handshake none
set flow-control none robust
set file type bin
set file name lit
set rec pack 1000
set send pack 1000
set window 5 c

And when running kermit I got:
?SET SPEED has no effect without prior SET LINE
?Not confirmed - robust
File: /etc/kermit/kermrc, Line: 26
?Not confirmed - c
File: /etc/kermit/kermrc, Line: 31
C-Kermit 9.0.302 OPEN SOURCE:, 20 Aug 2011, for Linux+SSL+KRB5
Copyright © 1985, 2011,
Trustees of Columbia University in the City of New York.
Type ? or HELP for help.

I observed that when I connect my Khadas to one of the USB interface in my old PC the lubuntu im my PC didn’t detect any periferal and it didn’t attach the USB to ttyUSB0. Is that the cause of not being able to connect the kermit?


#2

I think you didn’t done the Kermit configuration in right way, following document for your reference:

Actually, the ttyUSB0 is a device node of the USB-to-Serial tool, which should be found at /dev/ folder if your USB-to-Serial Tool has been pluged into your PC.

Have fun!


#3

Hi, thanks for the answer. Yes I follow the instructions on that doc. From USB cable I connected D- to Pin19, D+ to Pin18 and Ground toPin17.

I connect but no detection :frowning:
I have a Prolific PL2303 that lubuntu detects normally so the detection is working in my old PC. I disconnect the Prolific cable to avoid interference.

This was an attempt to follow one of the hints to solve my issue at

Kind Regards,
Paulo Keglevich


#4

Hello, I often see where reversing the DATA-, DATA+ connections will help.


#5

hi,

Thanks that works but now I get this:

Bus 002 Device 002: ID 058f:3820 Alcor Micro Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
ksc@Dev-lubunty:~$ dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 1.530751] 00:08: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 115200) is a 16550A
ksc@Dev-lubunty:~$ kermit
?SET SPEED has no effect without prior SET LINE
?Not confirmed - robust
File: /etc/kermit/kermrc, Line: 26
?Not confirmed - c
File: /etc/kermit/kermrc, Line: 31
C-Kermit 9.0.302 OPEN SOURCE:, 20 Aug 2011, for Linux+SSL+KRB5
Copyright © 1985, 2011,
Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/ksc/) C-Kermit>

Does you know what means ‘?Not confirmed’ ?

once in kermit how can I access the configuration of Khadas to alter the video resolution and frequency it uses?

I’m trying to reduce the video resolution and frequency in order to be able to operate the Khadas directly in its grafic interface.


#6

Hi keglevich:
Actually, have to say that you still haven’t set up the Kermit tool in right way at the moment, which is not related to Khadas.

Can you run below command and paste all the output:
cat /etc/kermit/kermrc

As from the output message you pasted above, it says that your kermrc configuration file have more than 26 lines, this is strange.

I haven’t try to set up with /etc/kermit/kermrc but with ~/.kermrc as the setup instructions in Khadas Docs

Have fun!