4G LTE chip with SSD in USA

hey there,

wondering how i can get set up with the LTE chip on my vim4. I am in los angeles and can get a sim card from my carrier t-mobile. i checked the chart of frequency bands and everything seems to work. since i want an ssd as well as LTE i can not use the 5g chip. are there any reasons i would not be able to have this setup working?

thank you!
D

@dofthed Is the 4G module you are using the official em06 module? or other modules you purchased yourself

just bought the khadas 4g chip, need to make sure i have the right sim card for it, want to make sure i’m not getting the wrong one

@dofthed Do you check with this docs ?

yes it seems like my carrier is supported, gonna try this friday

this doc is no longer available, is there any info or additional drivers for how to set up the 4G LTE chip? now when i attach the chip my ubuntu setup won’t boot.

@Frank @numbqq hey is there any information on setting up the 4g lte chip with the new m2x adapter. right now i can get my setup to boot with the 4g chip OR the nvme m.2 drive but will only turn on with a blinking white light when i have both installed

Please check here:

https://docs.khadas.com/products/sbc/vim4/configurations/em06-lte-4g-module

@numbqq the gnome walkthrough is from an out of date. when i follow the steps in the doc my system sees the modem but can not connect to 4g, and it says connection failed. is there a way to troubleshoot the modem? also, how do i enter the sim card pin?

hi @dofthed Can I confirm two things for you ?

  • Is the 4G module properly connected to the antenna ?

  • Whether the usbnet mode setting is performed as “superuser”?

I just did the test and my VIM4 is working fine,good luck.

also, how do i enter the sim card pin?

You can open the corresponding settings and update the password in mobile broadband. I believe the documents numbqq gives you can also help you very well :laughing:

by super user you meant i log in as root?

Yes, I think if for no other reason, you will get good results

@ivan.li i have ran the command as root but still won’t connect. the part that says ‘click network and add new connection’ in the walkthru looks nothing like the current version of ubuntu so i think that is where my mistake is coming in. any idea how i can troubleshoot?

I have a few suggestions

  • Install os into eMMC via OOWOW . The version I use —vim4-ubuntu-22.04-gnome-linux-5.4-fenix-1.2-221018.img.xz

  • Ensure that the usbnet mode is set successfully( LTE module needs power down and restart to switch mode. Unplug your SBC and plug again. LTE module now works in usbnet mode.)

  • the 4G module is properly connected to the antenna

Sorry, the new system may be slightly different from the picture description. I will update the picture soon. But it’s still useful, and you can get the most out of your intelligence without being limited by the differences in your documentation. Because the new system 4G connection process is much simpler. I hope you succeed. Otherwise, I would like to hear your detailed description of the problem

okay so i have installed everything from scratch, i got into root and used minicom to set usbnet. is there a way to check this works? then when i get into ubuntu desktop, when i go to mobile broadband i can see that its trying to connect, and there are multiple options that say US Mobile. they come up automatically so i feel like its not the antenna. When i add a new connection i dont know where to enter sim pin / account info / service provider

The easiest way to do this is to see ok appear

AT+QCFG="usbnet",2
 
OK

With the new firmware, 4G connectivity, you don’t have to do all that stuff. It’s smart, like the iphone.
If yours is not, I want some screenshot of you.( I want to help you out once and for all)

1 Like

i finally had time to flash everything and start from with a fresh ubuntu install. was able to get everything up and running. i was a noob with minicom and didn’t enter things correctly was likely what happened. also im not sure if you have to open up access points and add password of ‘000’

thank u so much, ya’ll were very responsive to everything i had a question about @ivan.li @numbqq