3rd-Party Ubuntu ROM for Khadas VIM

If the Wifi worked on the multi-DM, and then ceased to work in it, then the cause is most likely not in the software. Perhaps You changed something in the router settings or it ceased to work Wi-Fi. Have you tried to restart the router ?

I hope soon to write a small report about what I have done with VIM. My first impressions were rather interesting device, the first thing I liked - the design principle of the modular housing (its easy to change with minimal cost). The current design needs some work, but it’s easy to do.

I didn’t change any router settings, but i haven’t tried to restart it.

I don’t have any problems with wifi on my phone and Android Os on Vim, but maybe it would work if i restarted it.

One question, when you create bootable sd cards, they are formatted as fat32.

Is it possible to use it in ext4 format, and would you have any benefits with it?

First partition is FAT32, unseen from a Windows PC is the second EXT partition (rfs).

Yeah, i googled it a little later, that’s why it wasn’t showing me whole sd size after creating bootable sd.

It was strange to me that the whole card used fat32, i know that Linux uses ext fs.


1 Like

Balbes, i have tried to reset the router, it is still the same situation, no wifi.

Everything works more or less well, except this, i hope i won’t have this problem when official Mate comes out.

I checked this running Mate - Armbian_5.24_S9xxx_mate_Ubuntu_xenial_3.14.29_desktop_20170205.img from SD card.

There does seem to be a problem.
The network manager sees the WiFi module(device wlan0) and shows a MAC, but does not see my networks.
Under the notification area, network connections, WiFi is greyed out.
After many attempts to setup the network manager, no go.
Also could not use the WiFi module as a hotspot, shows device wlan0(and MAC), but nothing actually happens
Also will not pickup an unsecured hotspot provided by another TV box.

Sometimes network notification reports eth0 connected, even when no Eth cable is connected.

I think I will download the image again and re-burn the card.

In the next few days I’ll try to check.

Checked the latest image. Downloaded from the website (something to make sure that the file on the website is not corrupted). Recorded on the flash drive. Launched on VIM. Then show a video of my actions. The system found the available network, I enter only a password to connect. Pay attention - I not change Android, I just added multi-upload (via UART console, it’s easier and immediately see the result). The dtb file is used from internal memory. Maybe you have to handle the case could disconnect the antenna or broke the contact. Or use the dtb that is different from the regular one. Either the router is spelled out binding to MAC to the address, and he changed. Ideas from me yet.


1 Like

Pay attention, for those who use my images. I found the cause of the fall core at a temperature of 70 degrees in the images Armbian is a module “mali.ko”. Remove it from the system (for old images). On the website under Linux\Armbian\Test an updated version of the image MATE (20170228) with the correction (without the module “mali.ko”) and a few patches that improve the core.

Image MATE 20170205. Removed the module “mali.ko” . Under load (without fan) the temperature reaches 80-82 degrees - the system does not fall, continues to work.


Balbes, are you planning to make a Armbian debian server version? Or a Arch Linux Arm?


Images are downloaded from Debian. After some time they will be available. The version of the image with ArchLinux is on the site, but it has not been updated because no one asks about it. By the way, in the near future (after testing) images from the Test directory will be moved to the main directory, because I have limited place. If anyone needs the old version - download now in the future I will delete (to make room for new).

1 Like

New image (Test 20170303) correction module mali. Checked on S905X - everything works, the temperature is over 70 degrees, the system is not falling. Please check at home. Please check the work WiFi network.


hi, can you provide the kernel source for this image?


awesome thanks, also how can i boot from sd without android installed on emmc? emmc is empty right now.

All images Armbian default has a built-in u-boot. If no eMMC in u-boot, the processor should use u-boot from SD card (from armbian).
You need to rename the file s905_autoscript in aml_autoscript (replace the existing file with this one).

I just keep getting

on the serial uart.

ok it seems like the image contains uboot.bin and not uboot.sd.bin which is necessary for sdcard boot. flashing that and renaming the autoscript did the trick