Android Nougat(7.1.1) Source code available for download


hi, Davemf:
can you help to generate the manifest.xml to me, so I can check the uploading is okay:

$ repo manifest -r --suppress-upstream-revision -o manifest_github.xml

Then send file manifest_github.xml to me.



Run below command and paste the result to me:

$ aarch64-linux-gnu-gcc -v


Okay, now install the update and do it.

I have already started “Install Cross Compiler for Linux kernel:” again. I wait it.


My result

Built /home/davemf/project/khadas/nougat/uboot/build/board/khadas/kvim/firmware/bl21.bin successfully

CPP task_entry.s
aarch64-linux-gnu-cpp: error: unrecognized command line option ‘-mthumb’
aarch64-linux-gnu-cpp: error: unrecognized command line option ‘-mno-sched-prolog’
make[2]: *** [/home/davemf/project/khadas/nougat/uboot/build/scp_task/] Error 1
make[1]: *** [bl301.bin] Error 2
make: *** [sub-make] Error 2
davemf@ubuntu:~/project/khadas/nougat/uboot$ aarch64-linux-gnu-gcc -v
Using built-in specs.
Target: aarch64-linux-gnu
Configured with: /cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/src/gcc-linaro-4.9-2014.09/configure --build=i686-build_pc-linux-gnu --host=i686-build_pc-linux-gnu --target=aarch64-linux-gnu --prefix=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/install --with-sysroot=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/install/aarch64-linux-gnu/libc --enable-languages=c,c++,fortran --disable-multilib --enable-multiarch --with-arch=armv8-a --with-pkgversion=‘crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09’ --with-bugurl= --enable-_cxaatexit --disable-libmudflap --enable-libgomp --disable-libssp --with-gmp=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --with-mpfr=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --with-mpc=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --with-isl=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --with-cloog=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --with-libelf=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/.build/aarch64-linux-gnu/build/static --enable-threads=posix --disable-libstdcxx-pch --enable-linker-build-id --enable-plugin --with-local-prefix=/cbuild/slaves/oorts/crosstool-ng/builds/aarch64-linux-gnu-linux/install/aarch64-linux-gnu/libc --enable-c99 --enable-long-long
Thread model: posix
gcc version 4.9.2 20140904 (prerelease) (crosstool-NG linaro-1.13.1-4.9-2014.09 - Linaro GCC 4.9-2014.09)


Hi, Davemf:
It’s a issue u-boot repo, I’ve resolve it and sync to Github, please run the following commands to fix it:

$ repo sync


All is fine.

ACS tool process done.
3648+0 records in
3648+0 records out
3648 bytes (3.6 kB) copied, 0.00445016 s, 820 kB/s
6064+0 records in
6064+0 records out
6064 bytes (6.1 kB) copied, 0.00837757 s, 724 kB/s
…/fip/gxl/u-boot.bin build done!


next error:

make: Leaving directory /home/davemf/project/khadas/nougat/out/target/product/kvim/obj/KERNEL_OBJ' make wifi module KERNEL_ARCH is arm64 make -C /home/davemf/project/khadas/nougat/out/target/product/kvim/obj/KERNEL_OBJ M=/home/davemf/project/khadas/nougat/hardware/wifi/realtek/drivers/8189es/rtl8189ES ARCH=arm64 CROSS_COMPILE=aarch64-linux-gnu- modules make[1]: Entering directory/home/davemf/project/khadas/nougat/out/target/product/kvim/obj/KERNEL_OBJ’
/home/davemf/project/khadas/nougat/common/scripts/ /home/davemf/project/khadas/nougat/hardware/wifi/realtek/drivers/8189es/rtl8189ES/Makefile: No such file or directory
make[4]: *** No rule to make target /home/davemf/project/khadas/nougat/hardware/wifi/realtek/drivers/8189es/rtl8189ES/Makefile'. Stop. make[3]: *** [_module_/home/davemf/project/khadas/nougat/hardware/wifi/realtek/drivers/8189es/rtl8189ES] Error 2 make[2]: *** [sub-make] Error 2 make[1]: *** [all] Error 2 make[1]: Leaving directory/home/davemf/project/khadas/nougat/out/target/product/kvim/obj/KERNEL_OBJ’
make: *** [multiwifi] Error 2
ninja: build stopped: subcommand failed.
make: *** [ninja_wrapper] Error 1

make failed to build some targets (22:19 (mm:ss))


I’m out of office at the moment, the issue happen as I removed the unused wifi repositories and didn’t upload these repositories to Github.

You can refer device/khadas repo of android Marshmallow, try to delete the other wifi configurations and try to compile again. Following commit on marshmallow for your reference:


I did it (delete all realtek and qualcomm wi-fi).
New error:

[ 15% 5522/35581] Ensure Jack server is installed and started
FAILED: /bin/bash -c “(prebuilts/sdk/tools/jack-admin install-server prebuilts/sdk/tools/jack-launcher.jar prebuilts/sdk/tools/jack-server-4.8.ALPHA.jar 2>&1 || (exit 0) ) && (JACK_SERVER_VM_ARGUMENTS=”-Dfile.encoding=UTF-8 -XX:+TieredCompilation" prebuilts/sdk/tools/jack-admin start-server 2>&1 || exit 0 ) && (prebuilts/sdk/tools/jack-admin update server prebuilts/sdk/tools/jack-server-4.8.ALPHA.jar 4.8.ALPHA 2>&1 || exit 0 ) && (prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-2.28.RELEASE.jar 2.28.RELEASE || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-3.36.CANDIDATE.jar 3.36.CANDIDATE || exit 47; prebuilts/sdk/tools/jack-admin update jack prebuilts/sdk/tools/jacks/jack-4.7.BETA.jar 4.7.BETA || exit 47 )"
Jack server already installed in "/home/davemf/.jack-server"
Communication error with Jack server (28), try ‘jack-diagnose’ or see Jack server log
Communication error with Jack server 28. Try 'jack-diagnose’
Communication error with Jack server 28. Try ‘jack-diagnose’
[ 15% 5522/35581] target C++: libLLVMC…nal/llvm/lib/CodeGen/CodeGenPrepare.cpp
ninja: build stopped: subcommand failed.
make: *** [ninja_wrapper] Error 1

make failed to build some targets (16:41 (mm:ss))


It’s common issue about Jack server on Android Nougat, you can google for the instructions


solved: not enough RAM, added RAM and everything is OK.
Build was completed successfully.

using prebuilt boot.img from IMAGES…
amlogic extensions:FullOTA_InstallEnd
running: openssl pkcs8 -in build/target/product/security/testkey.pk8 -inform DER -nocrypt
running: java -Xmx2048m -Djava.library.path=out/host/linux-x86/lib64 -jar out/host/linux-x86/framework/signapk.jar -w build/target/product/security/testkey.x509.pem build/target/product/security/testkey.pk8 /tmp/tmpOIaRnI out/target/product/kvim/

make completed successfully (34:04 (mm:ss))


How much RAM size did you install before and now? :slight_smile:


before 4 GB, now 10GB for WMWare.


Source has not gapps, and ‘device/khadas/kvim/’: BUILD_WITH_GAPPS_CONFIG :=false


You can follow below steps to build gapps.


  1. Download the gapps file from github
$ cd <path-to-your-project>
$ cd vendor/amlogic
$ git clone -b naugat
  1. Enable GAPPS by edit ‘device/khadas/kvim/’:
  1. Build your rom again
$ cd <path-to-your-project>
$ make  installclean
$ make  -jN otapackage


Is it true for root?


It is invalid for root .
I will add the instruction for it when i complete the root .


Root on 7 is not as easy as on 4/5/6!


But without root it is not needed at all.


Well they will do it eventually… just take more time to find the solution.
From my tests i think i know the solution but i can be wrong!
And im really busy now with work and some other devices that i have to work on, and i still need to fix my compile PC… dead HDD…


Have You solved the problem with the root ?