4K UHD HDMI setup


#1

I’m using a VIM2 Max. I recently burned the DualOS to eMMC and the Android/Ubuntu setup worked great in the GUI & command line environment.

However, now I automatically boot into the Ubuntu command line and startx doesn’t seem to work. I have not been able to go back to either Ubuntu GUI or the Android GUI.

The VIM2 Max HDMI is attached to an new HP monitor (not 4K UHD) that works fine. I have a new 4K UHD monitor that just doesn’t work on the VIM2 Max. The 4K UHD monitor does work perfectly on other computers.

I am going to use the UBUNTU 16.04 as a server but it needs to be able to display specific 4K UHD information when required.

I am unable to find the display using xrandr, read-edid and other commands. “Can’t find display”.

1st: Can you explain why I can’t find a display that is connected through HDMI and working fine?

2nd: Once the display is found, I want to setup the default HDMI to auto-connect into 4K UHD mode. Can you explain how I can do this? I can use the cvt command to get the information for the following:

xrandr --newmode “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
xrandr --addmode ??? “3840x2160_60.00”

The “???” is the required display device name that I can’t locate. Is there a default display name I can use?

3rd: Can I just enter these commands or do I need to write a pre-mount script? If so, where do I put it?

Thanks for your help and have a good day.


#2

Hi colgeocol:
Which version ROM you installed on your VIM2 Max?

Thanks!


#3

Thank you for your quick reply.

I installed the VIM2_DualOS_Nougat_Ubuntu-16.04_V171028 using the Upgrade Via an USB Cable instructions, No problems on the installation. I did the installation a few days ago.

By the way, i stopped using the startx command yesterday and started using the sudo service lightdm start and now I can get into the GUI when needed. I am now able to look at the GUI settings for the display. Not a lot of information there.

On the command line side, I still can’t find my monitor. Setup of the other monitor will need certain specific information that I can only find using the command line approach.


#4

Any progress on this problem?


#5

Hi colgeocol,

Can you switch to GUI via Ctrl+Alt+F7 ?

Thanks.


#6

Unfortunately NO.

I tried Ctrl+Alt+F7 and it didn’t work.

I tried Ctrl+Alt+Fn+F7 and it didn’t work.

I tried sudo startx and it didn’t work.

I tried sudo service lightdm start and it works.

So, access to GUI MATE isn’t a problem.

My problem is finding the display from the command line using xrandr.

Have you been able to replicate my situation using xrandr on your system?

I appreciate your help.


#7

Hi colgeocol,

For version VIM2_DualOS_Nougat_Ubuntu-16.04_V171028 has this issue, you failed to enter GUI via startx,but for current version startx works, and we will release this month. And you can use balbes150’s Armbian builds, too,

It works well, you can setup the resolution to 4K.

Thanks.


#8

Thanks. I look forward to the new DualOS release.

Regarding balbes150’s Armbian version I assume you want me to use the latest S912 version.

I will try it too.

Were you able to detect a monitor using xrandr?

Were you able to detect a monitor using the read-edid App?


#9

I can execute it on terminal, can’t on framebuffer console

khadas@Khadas:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      0.00* 

Executed failed, I’m not sure what’s going wrong:

khadas@Khadas:~$ sudo get-edid 
This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
Problem requesting slave address: Device or resource busy
No EDID on bus 1
No EDID on bus 2
Looks like no busses have an EDID. Sorry!
I'm sorry nothing was successful. Maybe try some other arguments
if you played with them, or send an email to Matthew Kern <pyrophobicman@gmail.com>.```

#10

I now run my VIM2 Max tied to a HDMI EDID monitor using VIM2_Ubuntu-server-16.04_Linux-4.9_V170922 installed in the eMMC. My framebuffer /dev/fb0 is active.

Because xrandr is for the X11 GUI, do I have to install:

VIM2_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31
or
VIM2_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31?

Or is there a way to enable, connect and activate HDMI using a script or by installing an apt in my current installation?

If so, could you show me how to do it?


#11

Hi colgeocol,

You can try VIM2_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31 and use the following command to setup the resolution to 4K.

khadas@Khadas:~$ fw_setenv hdmimode 2160p60hz
khadas@Khadas:~$ sudo reboot

Thanks.


#12

I burned the VIM2_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31 image into the eMMC.

The first thing I noticed was that /sys/class/drm only contained version while my previous image had card0 and version

After setting a static IP address, I entered your suggested commands:

 khadas@VIM2Max:~$ fw_setenv hdmimode 2160p60hz
 khadas@VIM2Max:~$ sudo reboot

After the reboot, the HDMI still didn’t show up.

Any other suggestions? A boot script that could enable the HDMI would be preferred.

Thanks.


#13

Yes, DRM is not available.

You can modify /boot/hdmi.sh to setup HDMI resolution, but the priority of u-boot command line is higher than mode you set in hdmi.sh.

By the way, your monitor doesn’t support 1080P? The 4K display is not good for Ubuntu, the menu icons and font are too small…