Windows 10 not recognizing Khadas tone board?

I bought a Khadas tone board 3 months ago and it was working fine until a few days ago. Suddenly I can no longer get my laptop to recognize the board. I’ve tried different cables, uninstalling and reinstalling the drivers and it still won’t work. Could someone help me with this?

Does the Tone Board’s LED light?

Yes it does light up

I have it in a case and don’t have a screwdriver with me atm. I will try this tomorrow

I could mix up, friend, I thought you had a problem with the main board Khadas, sorry, good luck!

I’ve done all that already and it still doesn’t work

need to remember after which it stopped working!

It just doesn’t recognize the board when I connect the board to my laptop. There’s no option for the XMOS.

Did it coincide with a Windows 10 update?
Have you tried the Tone Board on another device/PC?

I have tried it on other devices/pc and it still doesnt work. I dont believe it coincided with an update

As you have tried the above, plus different PCs and devices, you may need help from one of the Khadas Team. As you may know, the Coronavirus quarantine is keeping the Khadas Team from being able to return to their offices. Official assistance will likely be delayed.

I am curious, the cable you use and the ones you used for testing, are they all USB-C to USB-A cables?

Yes they were usb c to usb a

If the khadas team is back to work can i get help with this?

you do not know whether it is possible to restart the board?

I dont know whether thats possible or not

can someone from the khadas team be able to tell if it is possible to reset the board

@Vladimir.v.v Maybe @Gouwa and @tsangyoujun can help you anout toneboard .

Hi @Jcc4219
Can you help to take some HD photos with both sides of the KTB and post here?

BTW, can you tell us where you purchased the KTB? I will let the sale service to follow up this.


I bought it from amazon sold by SmartFly info which I believe is one of Khadas distributors when I looked at the list. I will post pictures in a bit. I have it in a case so I need to take it out first.