Wifi Troubles with Edge2

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Its what ever you installed when shipped to me

Please describe your issue below:

I cant get your firmware to connect to wifi. It keeps saying it fails on the password but I have typed it exactly how the router says it should be. The password has special characters in it - Shift+number keys ones. I have tons of other devices all connected using that same password with no issue. Is there some limitations with this devices wifi? 2.4 only? Password character limitations in the software?

Post a console log of your issue below:

I cant get this thing online to access outside of it self to get this

Firmware shows beta 220902.00

Hello @dping28

@hyphop will help you here.

please send your wifi password to PM for me, i will check on my network equipment, and i will notify you later

Hello @hyphop , Unfortunately I don’t appear to have the ability to send you a PM. Clicking on your avatar there is no message button and I cant find any option within your profile or my main menu in the top right. I can be blind at times so its probably staring me in the face somewhere.


For situation like yours (no internet connection for device)

  1. download latest version http://dl.khadas.com/products/oowow/system/edge2-oowow-latest-spi-upgrade-sd.img.gz
  2. and write it to SD or USB-flash
  3. boot from from this disk - wait upgrade will be complited

PS: read more detail how-to manually upgrade http://dl.khadas.com/products/oowow/docs/oowow-how-to.md#manualy-restore-oowow-spi-flash-firmware


Thank you for the quick fix, im having a bit of an issue flashing it though, hope you can tell me what im doing wrong. I am running linux so I used dd to flash it:

sudo dd bs=4M if=Downloads/edge2-oowow-230113.000-spi-upgrade-sd.img of=/dev/sda status=progress oflag=sync

I tried it first as the img.gz then I extracted and tried as just .img. Neither seem to do anything when I boot off that usb. I have pressed Func+Reset with the USB in both ports but just boots right into oowow and nothing else.

I got it and it fixed the issue with the wifi! Thnx again! In case anyone else cares I had to extract it then run that dd command then with it plugged in just reboot, no need for the buttons. it flasshed and reboot again with the usb out and I could connect to wifi. Thanks so much hyphop!

I would like to share my problem as well as it might be useful for others facing this issue.

Even after upgrading to latest spi upgrade my problem didn’t go away. As the OP i also have been using some special characters in my wifi pwd which require the use of Shift+number keys. Only solution that worked for me was to change my router’s wifi pwd to regular alphabets and digits, no special character. I assume the problem is with OOWOW 'cause none of this matters once you install an OS.

Please share this information for me via PM and I will try to fix it in next version

Let me now what info you need and i’ll try to fetch it for you.

I’m talking about your password for wifi with special characters to PM for me :wink:
sure u can change little bit your password if its a big secret

I try to find problem and fix it in the next version

PS: before we have a similar problem, which was fixed