WIFI does not appear after enable spi1

I have a problem, when I enable spi1 the wifi network disappear just ethernet keep working.
Can someone figure what is happening?.


Hello! Does Wi Fi cost 2.4?

@vaayroon Please elaborate your problem,
Verify that you don’t have any kind of power supply problem,
You did not wrongly modify the DTB etc.

there is some information, maybe it will help

I believe you are trying to say, Does the Wi-Fi work at 2.4 Ghz,
Right ?

Yes, there is a conflict between usb3.0 and WiFi, maybe there’s a problem

But that problem existed only with USB 3.0, how could SPI be a problem ?, its clockrate is not even high enough to cause interference with USB 2.0 !

and who said about him?

It is an emphasis to show how low the interfering frequency is,
this bit of article can explain,

i just edit device tree as following:

SPI from disabled to okay

&spicc1 {
status = “okay”;
pinctrl-names = “default”;
pinctrl-0 = <&spicc1_pins>;
cs-gpios = <&gpio GPIOH_6 0>;

spidev@0 {
	status = "okay";

	compatible = "linux,spidev";
	/* spi default max clock 100Mhz */
	spi-max-frequency = <100000000>;
	reg = <0>;


and PWM_EF from okay to disabled

&pwm_ef {
status = “disabled”;
pinctrl-names = “default”;
pinctrl-0 = <&pwm_f_pins2>;

after that spidev is activated but wifi doesnt appear in network connections, actually if I make ifconfig and iwconfig in CMD, wlan0 (the wifi) doesnt appear.

Have you tried iwconfig ?, by the way which ROM are you using I forgot to ask :sweat_smile:

Please try using the following command and see if Wi-Fi starts working again:
sudo ifconfig wlan0 up

@vaayroon Hello . Can you disable spi and try again with wifi ? I think there should be no conflict between spi and wifi

@Electr1 @Vladimir.v.v I think this is not the same problem with USB and 2.4G conflict . That just about USB not SPI


@Frank if you take a closer look at my post that was what I was saying :grin:
I only took USB as a case example, because of that frequency problem

If SPI is not even able to interfere with USB 2.0 (because of such low frequencies), how could it mess with the USB 3.0 or WiFi frequency range

Of course, this is in the case of hardware conflict, if it was just a software bug, it could be solved another way.

But the latter has not given details of the ROM used, so if he told that, we might be able to narrow down the cause :slightly_smiling_face:

hi, thanks for the information, I honestly don’t know about other hardware conflicts, so I suggested

I am using VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190830

Finally I was able to enable spi and wifi at the same time.

I realized that when I enable SPI but PWM_EF keep enable in DTS file, spi does not appear when i run (sudo ls /dev*) but wifi works, and when I disable PWM_EF in DTS file, spi appear but wifi disappear.

So I tried changing the pinctrl-0 from &pwm_f_pins2 to &pwm_f_pins1, I saw it in another discussion, https://forum.khadas.com/t/vim3-gpio-wiringpi-spi/5893/11:

&pwm_ef {
status = “okay”;
pinctrl-names = “default”;
pinctrl-0 = <&pwm_f_pins1>;

after compile and burn the image in emmc using UTILS, both spi and wifi are enabled.

But now I have a question, why that change works?.
And changing pins from &pwm_f_pins2 to &pwm_f_pins1, How can that change affect me and my vim3 khadas and what are those pins1 and pins2 means?

Thank you all for your time.

@Frank @Electr1 @Vladimir.v.v


Hello! By the way, you wrote in the vim3 theme, you have vim1, this confused us

My bad, updated. i am using vim 3 not vim 1.

1 Like

Ok, that’s good to hear :slight_smile:

yes, sometimes it’s easier to deal with your project yourself