Wifi AP6398S + mainline kernel

failed ;(

Hi
This bcmdhd.1.579.77.41.x wifi driver can’t help for AP6398S support for mainline?
https://mega.nz/#!lF12xQYS!u3ajDN2tPnYrCzs1i4qhliUKl3UQP4pPN0C300grb3g

@hyphop, @balbes150 Can test if this wifi driver works?
It was confirmed compiling fine on kernel 5.3.0-rc5.

Can you advice me on how to add this to the package? So I can try and compile the kernel along with this and give it a try.

yes its possible to build ! but still not work!)

i try to solve this problem but some need time !

Please share your experience and also logs if you can get it.
I will pass it on to Rockchip and Ampak, maybe they can help to solve the remaining problems.

Broadcom/Ampak already ignored requests from Google re. mainline support so I wouldn’t raise your hopes on getting a response :frowning:

Hi Khadas team,

I found these links whilst evaluating whether to purchase the VIM3, as working wifi is critical to my situation:

And

Is there anyway this can be tested to determine whether it is a viable workaround whilst mainline support is missing?

For testing devices that frequently don’t have working WiFi from the comfort of my sofa (without using a 15m Ethernet cable) I acquired a used Apple Airport Express from eBay ($15). it’s configured in bridge mode so that any device I plug in via Ethernet has reliable WiFi with no dependencies on drivers, kernel versions, etc. … just a suggestion.

Apple Airport Express - need power from adapter (or its same by usb cable connected to same device )? + and price about 50USD and up, i think any usb wifi dongle with true supported chip its easy and price only 5 USD

PS: i have use orange-pi devices its just 10USD for same bridge usage , but he provide usb-ethernet <=BRIDGE=> wifi , and use only one usb cable and same no need special drivers )

@chewitt I sense some irony :slight_smile: :

.
It appears VIM3 is shipping without working WiFi on many Linux distributions, even though its datasheet advertises Wifi AC as a feature.
.
There is nothing wrong with wanting / needing it to work for a specific use case, is there?
.
If there is an issue with my suggestion to use a patch that appears to have worked in making wifi useable on another board using the same chip, please let me know. It it is not applicable, I’d be interested in understanding why :slight_smile:
.

u can use on-board WIFI with legacy kernel from khadas amlogic, its work !

but mainline kernel still not have support for this wifi chip!

1 Like

It uses mains power (240v) and the last one I bought (used) was $13 inc. postage. If you want to support cheap Realtek USB devices with shit out-of-tree drivers, be my guest. I don’t :slight_smile:

may be its 15 )) but real price for new apple devices is about 100$-150$ USD i think is too much ))) be sure normal cheap wifi dongle works same fine)))

why ? u dont like realtek ? ))) for me its lil strange

linux-kernel have good support for many realtek wifi chip RTL8xxxx
i have some very nice devices and cheap same time, its work without problems ! whats problem ?

It seems to me that we are talking about mainline support of ampak AP6398, containing Broacdom bluetooth and wifi chips, not Realtek…

1 Like

I also think the new price is expensive, which is why I buy them used on eBay for $13 instead of new for $100-150. Good luck supporting your users with cheap Realtek USB dongles. The mainline kernel has support for older b/g/n chipsets not the current shipping b/g/n/ac chips that most users want to use. The newer chipset drivers are not in-kernbel and are not maintained by Realtek using any public sources, and they break with every kernel bump. That’s my definition of a crap driver. Your definition and tolerance may be different to mine.

Anyway… please focus your time figuring out how to get mainline kernel support for the Ampak module that ships in all of your boards.

2 Likes

When can we expect a working driver for VIM3 wifi on Linux side?
I see CoreElec have working wifi with 4.9 - Just for info.

Maybe this time next year if we’re lucky.
I already posted the latest kernel AP6398S driver from Ampak that they have working on non Amlogic, Rockchip devices using the 5.3.0 mainline kernel. So someone just has to modify the code to get it working and troubleshoot.
The 4.9 kernel driver code CoreELEC uses will also not work on the 5.3.0 kernel since it’s even older.

Sure is, I’m not a lover of Realtek chips either, but they just work

Hello,
Can you guide me to the codes that needs to be modified?

As i see ap6398S firnware is provided by rockchip devices but we’re not able to use the same on vim3.

Can someone advice on how we can make use of it?

The 5.3 kernel driver also doesn’t work on Rockchip devices.
Also doesn’t seem that anyone tried to test it in the last 2 months, which is sad since both the Khadas Edge-V Pro and VIM3 uses this wifi chip.
Maybe someone will try to pick it up and test it again, if it works on Rockchip then it will have a better chance to also work on the Vim 3 later.