VTV App not scanning properly

@Frank.DTV, @balbes150 et al,

Android Build Number: VIM2_Nougat_20171123
VTV Version: Version 1.0 (com.superdtv)

Autoscan for channels ‘stalls’ halfway through on both DVB S/S and DVB T/T2. I have to exit out of the scan mode - but no channels are stored.

I have installed Android, Ubuntu Mate and Libreelc all on eMMC as per @balbes150 instructions on MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC

Is there a way to reinstall the app? Or should i put an SD card in SD Card slot as channels have to be stored somewhere?

Stalled scan

dear @michaelnewham

  1. please try manual scan for both DVB S/S2 and DVB T/T2, to check if hardware connection is ok or not
  2. if point 1 still not working, please check the pogo pins connection betweent VIM2 & VTV. Make sure they are connect well
  3. if you want to reinstall the app, just take an Android Factory Data Reset.
1 Like

Hi @Frank.DTV, cc: @balbes150

Unfortunately the above does not work :frowning:

I thought it was a fault on the original VTV board (version 2.2) so I ordered a new one (version 2.3).

But after carefully attaching the new VTV board to Khadas VIM 2 I had the same issues as before…
In that the scan for DVB S/S2 would not proceed (auto or manual) and scan for DVB T/T2 (auto or manual) got as far as 56% but no more.

I then did a factory reset and installed an app to check that permissions and storage were not an issue. The app (Terrarium) installed correctly…

Situation then got worse - all that comes up now is 'VTV Board Not Detected". Even though the board and the Vim 2 are being powered by the VTV power adapter.

Any other ideas on how to proceed?



(P.S. The two aerials do work, one for terrestrial tv and the other for satellite tv for other devices)

(P.P.S Original board worked fine prior to my MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC installation

Install the firmware with one of the regular Android .

Hi @balbes150 cc: @Frank.DTV

Which method will i use to upgrade ‘Android firmware’ as per the instructions on -http://docs.khadas.com/develop/HowtoBootIntoUpgradeMode/

a) Keys Mode(U-Boot is running)
b) Serial Mode(For developers)
c) MRegister Mode(Maskrom Mode)


Will i just follow the instructions as found on Khadas Docs? - Download the Android Source Code



You can use the standard firmware upgrade via USB cable or SD card.


dear michaelnewham
Did you ordered a new one?
And if so is it working well?

Where do you order the VTV board and do the satellite work?