Volumio for Khadas

Hello! I burn the image Volumio-0.6-2018-02-16-vim-armv7.img on the SD card
But I do not find where to specify that it would boot from the SD card.
Power ON with the F button does not help.

It’s written in many topics!
Read the forum plz.
I can’t write it step-by-step on the fly but in general you need to go in android settings, update, load … chose the .sh from the SD card … update
this will reboot your VIM from SD and every time you have SD/USB installed will use it as a first boot option.
If you want o install Volumio on eMMC you need to do install.sh from root folder (if i remember correctly)

It’s all about reading :wink:

Okay! Waiting for the Tone Board, this is my audio setup, based on VIM2 (LMS, Spotify Connect, AirPlay, UPnP, Airsonic and of course ROON), XMOS and AKM DAC … and some good analogue power for less than 250 usd. Next step is to make a good case :wink: I want to thanks once again to balbes150 for his builds of Armbian :slight_smile:


Hello! I installed Volumino in emmc, but it still loads for a long time, about 35 seconds, I thought it would be faster. Most of the time I see the letters Khadas, as if the bootloader is waiting for something.
Tell me please how to load the WI-FI module

1 Like

One more bug is found on Volumio: Russian fonts are not displayed.

Please check new kernel and dtb file on the VIM1 (s905X) in the mode of audio output to HDMI. You need to download two files (zImage and dtb.img) and replace them on the SD media. After downloading with the new files you need to enter the settings and select the device HDMI\toslink. I have VIM1 it has fixed audio output on HDMI. In the near future I will release a new release of Volumio with support for audio output via HDMI to VIM1 and VIM2.


Added the dtb file for the VIM2 (s912).
To use it you need to download and rename the correct version of the file in the “dtb.img”.

1 Like

The new version of Volumio 0.7_20180325. It works a audio output through a standard HDMI output. To use this feature, you need to use one of the two dtb files. For VIM1 (S905X) - “kvim_android.dtb” for the VIM2 (S912) - “kvim2_android.dtb”.

@Gouwa @Stefan I have a favor to ask - check out this version with a S\PDIF.

1 Like

Can you give more information how to check this mode (sample files that can be checked) ?

All files rip from cd.
Tes es sabre dac es9018k2m es9028q2m

Can you throw me a specific file to check ?

Любой mp3 файл грабленый с компакта или даже wav или flac у которого 44 кгц частота.

Only to i2s?! This is strange if no problem on HDMI/spdif. Where you have read about this? What about 88.2Khz? It sounds more like rpi problem :slight_smile:

Я увлекаюсь звуком.
Поэтому перетестил почьти все одноплатники raspberri pi 3, odroid c2, orange pi pc, khadas vim2, asus tinker.
И стараюсь проверить их как по i2s используя DAC es9018k2m es9028q2m pcm5102 pcm5112.
Так и через usb - amanero xmos.
Те у которых есть spdif то и через него. ( но через него большой джитер).

If you have trouble scanning your music library you need to perform MPD upgrade. SSH to your volumio:

sudo systemctl stop mpd
sudo apt-get install libsidplayfp3
cd /home/volumio (or cd )
wget http://repo.volumio.org/Volumio2/Binaries/mpd-DSD/mpd_0.20.18-1_armhf.deb
sudo dpkg -i mpd_0.20.18-1_armhf.deb
sudo systemctl start mpd

test :slight_smile:


you need to change MPD from v 20.6 to 20.10 or newer one! 2.18 for example.
20.6 have bugs and can’t scan tags and add to library some file formats (aiff for example)

If you have tried to install LMS plugin in volumio you know it’s not working on Khadas! So this is step-by-step how to install it manually which worked for me. I have used install.sh from the original plugin but with different sources to get compatible with vim packages (do not install CPAN patches from the original install.sh!!!):

cd /home/volumio

sudo apt-get install libio-socket-ssl-perl lame unzip -y

wget http://downloads.slimdevices.com/nightly/7.9/sc/6c111ddc1267b1a6977ae42a0a783482c5de63ed/logitechmediaserver_7.9.1~1522249619_all.deb

sudo dpkg -i logitechmediaserver*

sudo chown -R volumio:volumio /var/lib/squeezeboxserver

usermod -aG audio squeezeboxserver

wget -O /home/volumio/CPAN_AUDIO_DSD_7.9.tar https://github.com/Saiyato/volumio-lms-plugin/raw/master/known_working_versions/CPAN_AUDIO_DSD_7.9.tar

sudo tar -xf /home/volumio/CPAN_AUDIO_DSD_7.9.tar -C /opt

wget -O /home/volumio/DSDPLAYER-BIN.zip https://github.com/Saiyato/volumio-lms-plugin/raw/master/known_working_versions/DSDPLAYER-BIN.zip

sudo unzip -o /home/volumio/DSDPLAYER-BIN.zip -d /usr/share/squeezeboxserver/Bin/

sudo wget -O /etc/systemd/system/logitechmediaserver.service https://raw.githubusercontent.com/Saiyato/volumio-lms-plugin/master/unit/logitechmediaserver.service

1 Like

Uploaded an update of Volumio image 20180401 for Amlogic S9xxx (s905x s912) to the site. This image is used to start the system from USB media. Another significant change. You can now quickly edit the command-line parameters that are passed to the kernel without having to build a new script. Parameters are stored in a plain text file, uEnv-volumio.ini, which can be freely edited.


I thing it is better to write instructions in step-by-step how to, because not all readers interesting in Volumio are linux experts :wink:

yes, this is a problem but a consequence of building a generic script for various tv boards.
It needs users to do some post-install additions and Volumio updater is not available.
I’m following the discussion to decide if we should perhaps have a Khadas-specific build at some point after all (without the user having to interfere).
Not convinced yet that it is needed, but the basics have been tested, including Volumio updater.

1 Like

balbes150 is a kind of genius for khadas! He made almost all of the firmwares including Librelec, Armbian and Volumio. What i am trying to say is that DYI community need more simple explanation. Not all of us are linux experts :wink: That is all.

1 Like