Volumio for Khadas


#138

По какому пину работает?


#139

gpio176 (PIN37 GPIOH5)
Все описано в readme
Если на пине 1 (3.3 volt) то работает если убрать то пауза и таймер.
Я через оптрон в машине сделал.
Таймер выключения около 60 сек ( но легко можно поменять на то что нужно)


#140

Hi, balbes150

Here is the khadas IR remote configuration. :grinning:

# Khadas's IR Remote Configuration
#
# The default button configuration for Khadas's stock remote controller.

begin remote

  name          lircd.conf
  bits              16
  flags         SPACE_ENC|CONST_LENGTH
  eps               30
  aeps              100

  header            8964 4507
  one               544  1692
  zero              544   561
  ptrail            544
  pre_data_bits     16
  pre_data          0xFF00
#  gap               107872
  toggle_bit_mask   0x0

 begin codes

  KEY_LEFT              0x000E
  KEY_RIGHT             0x001A
  KEY_UP                0x0003
  KEY_DOWN              0x0002
  KEY_OK                0x0007
  KEY_HOME              0x0048
  KEY_BACK              0x0001
  KEY_MENU              0x0013
  KEY_VOLUMEDOWN        0x0058
  KEY_VOLUMEUP          0x001A
  KEY_POWER             0x0048

 end codes

end remote


#141

Updated the images on the official website of Volumio. Those who wish can test them.

http://updates.volumio.org/aml9xxxarmv7/volumio/2.394/volumio-2.394-2018-04-14-aml9xxxarmv7.img.zip


#142

I tried to add a settings file for the remote control Khadas, but it does not work yet. You may need to change something else in the General settings.


#143

If you are not Wi-Fi adicted, the best image for volumio is still Volumio-0.4-2018-04-05-aml9xxxarmv7.img frpm balbes150. It’s sounds much better than the “official” from volumio download site
Wi-Fi is important for RPi users becouse RPi zero don’t have RJ45 by design for example. For VIM my suggestion is to use wired connection with no Wi-Fi.


#144

The first installation of Khadas VIM2 + Volumio in the car and the first visit to the competition in sound quality.
The result - the winner of the absolute class - the highest class, stronger system!

After this victory, all participants will move to buy Khadas.
Now we need a sleep mode (hibernation) with power save mode like on Android, as volumio is loaded for a very long time.

See more about this car.

Please give us power save mode for volumio :slight_smile:


#145

aha, real good job! :wink:


#146

Congratulate :slight_smile:

I’ll see what I can do, but I don’t promise it will be fast (summer is a holiday period …). :beach_umbrella:


#147

@balbes150
Thank you for help and volumio ROM!


#148

The second installation of Khadas VIM1 + Volumio in the car and new visit to the competition in sound quality.
The result - the winner of the absolute class - the highest class, stronger system, AGAIN!

See more about this car.

@balbes150
Thank you for your great job!

PS: please add suport USB multimedia keys and power save mode.
Many thanks!!!


#149

О каких ключах речь ?


#150

Привет.
Речь идёт о простой юсб клавиатуре с мультимедийными кнопками. Чтобы можно было подключить клавиатуру к волюмио и переключать треки и на паузу ставить.


#151

Это надо @Stefan и @gkkpch спросить, существует ли вообще такой функционал в Volumio, там же вроде управление через вэб-интерфес работает.


#152

Давай проще через gpio напишем.
Пиши чего надо сделать.
Трек вперед назад пауза и плей ?
Я такое уже сделал другу на проводной интерфейс алпайна.
Напиши в личьку если что.
Я ж тоже на соревки в экспертах выезжаю (пока чемпион)


#153

Hello, is it possible to use the allo isolator with the vim2 at the i2s signal. My idea was to connect the i2s pins, the 5V pin and ground from the vim2 with the isolator and than to the dac, but this way don’t funktion. By the way I see, that at the 5V pin at the vim2 are only 4,85 V.

Thanks for answer
Sebastian


#154

#155

I’m using CM6631A as my USB DAC. It works OK on my PC, and I plug CM6331A into the USB port of volumio, volumio can recognize it, but I can’t hear any sound from it. Then I use XMOS instead of CM6631A, connect to volumio, everything is OK, the setting of volumio is all the same, so what’s the problem? I have tried both Volumio-0.7-2018-05-20 and volumio-2.419-2018-06-29, and got same result.


#156

You may need to change the MPD settings.


#157

Thanks for replying, can you tell me which setting? I have tried MPD playback settings, including Audio Output(CM6631A) and Mixer type(Hardware,Software,None), but nothing happens.And the volume is set to 100.