VIM4 Wake on LAN not working

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu via OOWOW

Which version of system do you use? Khadas official images, self built images, or others?

Khadas Official

Please describe your issue below:

I used these instructions: Wake-On-LAN | Khadas Documentation

I can’t seem to get Wake on LAN (WoL) to work. I’ve enabled it in OOWOW, and it shows as enabled in the app in Ubuntu.

It didn’t sound like I needed to go into the KBI if I used the OOWOW method, is that correct?

Otherwise, how do I actually get into the KBI? I read the instructions ( KBI Guidance for Khadas VIM2/VIM3/Edge | Khadas Documentation ), but was confused.

Before continuing, make sure you have booted into U-Boot:

1 normal power off
2 boot wol: enable
3 Hit Enter or space or Ctrl+C key to stop autoboot -- :  0 
4 kvim2#

I’m not sure what to make of those instructions.

If you already enable the WOL in OOWOW, you don’t need to set KBI instructions anymore.

You can unplug the power cable and replug the power cable, the board will not boot automically, and the red LED will ture on, at this time, you can use command to wake the device.

$ wakeonlan XX:XX:XX:XX:XX:XX

XX:XX:XX:XX:XX:XX is your device mac address.


It wasn’t clear to me that I needed to unplug it and plug it back in. I assume that resets … something … on the board?

I’ll try that this morning and report back. :slight_smile:

This still didn’t work, unfortunately.

I also tried setting the OOWOW firewall to allow in-network connections, and that works (I can SSH/web console in to OOWOW when the system is off. Neither my Mac nor my router can wake the machine from sleep, however.

I’m starting to wonder if the ethernet cable might be the issue. Either that, or the switch is blocking the magic packet somehow.

Please make the following:

  • Unplug and replug the power cable, what’s the status of the LED?
  • Connect VIM4 and your PC to the same router


  1. On unplugging and plugging back in, the front LED goes solid white for a few seconds, then solid red.
  2. Both the PC and the VIM4 are both plugged into the same switch.

Okay, it is correct status.

Are you sure you use the correct MAC address of the board?

$ wakeonlan XX:XX:XX:XX:XX:XX

It would be the MAC in the Device Information’s Serial line in OOWOW, correct?

You can scan the QR Code on the board to get the MAC address.

Thanks. I used a QR code scanner and got the exact same MAC address I was already using, so at least I had that right.

It doesn’t work with the wakeonlan command, either. So far, I’ve tried it with wakeonlan, two different network management apps on my Mac with wake on lan capability, and an app on my iPhone.

I did notice that wakeonlan is defaulting to port 9. Is that correct for the VIM 4’s WOL function?