[VIM3L] USB touch doesn't work on Android

Hi everyone. I recently bought a 7inch touchscreen, the display itself works perfectly however the USB touch doesn’t. I haven’t connected any other USB devices so there shouldn’t be any compatibility issues. Tried both USBs. Touch works on windows and linux. Tried all android builds, no result.
Guess the problem is related to driver issues.

Here is the vendor and product info

USB\VID_0416&PID_C168&REV_0000&MI_00
USB\VID_0416&PID_C168&MI_00

The link to the display

https://www.amazon.com/gp/product/B07S51QDTG/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

How can I solve the issue?

I’ve been asking for some expanded/generic touch support for a while, to no avail. The Khadas team has been great about adding requested features (like USB GPS) so I’m glad to see that more people are requesting this feature. Hopefully @Terry & co can get this sorted out.

You are right. My VIM3L Is a great board with a lot of great features. The only issues are the poor support of USB touchscreens and some display resolution issues. I am sure @Terry and the team will figure this out overtime. Meanwhile my board is in the drawer waiting for it’s time to come.

1 Like