VIM3L: Ubuntu firmware images?

I dd’d the ubuntu-server image[1] for VIM3 to and SD card and tried booting on my VIM3L board, and it does not work (log below[2]).

It appears that it’s trying to init an A53 cluster and an A73 cluster, which means it’s trying to init an S922X SoC for the normal VIM3.

The docs should be updated to indicate that the Ubuntu images are for VIM3 and not VIM3L.

Are there any plans to support VIM3L with the Ubuntu images?

https://dl.khadas.com/Firmware/VIM3/Ubuntu/SD_USB/VIM3_Ubuntu-server-bionic_Linux-5.3-rc4_arm64_SD-USB_V20190830.7z

[2]
SM1:BL:511f6b:81ca2f;FEAT:A0F83180:20282000;POC:F;RCY:0;EMMC:0;READ:0;CHK:1F;READ:0;CHK:1F;READ:0;CHK:1F;SD?:0;SD:0;READ:0;0.0;CHK:0;
bl2_stage_init 0x01
bl2_stage_init 0x81
hw id: 0x0000 - pwm id 0x01
bl2_stage_init 0xc1
bl2_stage_init 0x02

no sdio debug board detected
L0:00000000
L1:00000703
L2:00008067
L3:15000020
B2:20282000
B1:a0f83180

TE: 371467

BL2 Built : 19:22:01, Jul 31 2019. g12b ge9a9000 - zhiguang.ouyang@droid07-sz

Board ID = 7
Set A53 clk to 24M
Set A73 clk to 24M
Set clk81 to 24M
SYS1 pll lock check retry
try t0…
SYS1 pll lock check retry
try t1…
SYS1 pll lock check retry
Stop here…

Hello, Firmwares are under their respective categories, VIM3L category is here. Also VIM3L is used in the name of VIM3L images.
I see no SD images yet.
I do not have the VIM3L, but it is possible balbes150 has an Armbian for it that boots from SD. I will check it tonight when I get to the tech.
VIM3 uses an A311D SoC, VIM3L uses an S905D3 SoC.

Update: @khilman The Armbian images of balbes150 are somewhat universal. After the card is burned there is a folder on the root called dtb. This folder contains dtb files for many devices, including the VIM3L.


Also on the root of the card you will find a file named uEnv.ini. It is necessary to edit this file, any text editor should do.
Open uEnv.ini and you will see like below, notice the selected text.

Replace the selected text with the name of the VIM3L dtb file, then save and exit text editor…

Unmount/Eject the card and insert in to VIM3L. With the power connected but VIM3L off, Press and hold the power button, while holding the power button, briefly press the reset button, continue to hold power button for 5 more seconds, then release. This button sequence is only necessary for the first run. After that, if the card is inserted, Armbian will boot. If card not inserted, OS on eMMC will boot.
Initial User is root
Initial password is 1234
I used the Bionic Desktop image from here for this example. Do keep in mind, having no VIM3L means I have not tried it on VIM3L.

I just downloaded VIM3_Ubuntu-xfce-bionic_Linux-5.3-rc4_arm64_SD-USB_V20190830.7z from https://docs.khadas.com/vim3/FirmwareUbuntu.html, it turned out to be an Android image :joy:. Could you please fix it?

I’m just testing the VIM3 I just received, really don’t care as long as it works, I’m going to build my own Debian mainline image anyway. But for those seriously want it, they will be pissed off.

I just downloaded the image, this image is only for VIM3 not for VIM3L.
I burned the image to an uSD card, booted right up to Ubuntu, it is not an Android image.
Assuming you have VIM3, are you sure you followed the instructions carefully?..

Note: The following sequence is an excerpt from instructions to Boot/Run OS from Card or USB drive. Does not apply to Flashing using the USB Burning Tool.

" Step 3. Boot VIMs from SD card or Thumbdrive

There are several ways to boot (activate multi-boot) from the SD card / Thumbdrive:

  • Via Keys mode (Side-Buttons) - the easiest and fastest way
  • Via Android
    • Enter Settings->About Device->System->Updates .
    • Click select and choose aml_autosript.zip .
    • Click update, then the system will reboot and boot from the external media image.

WARNING: Don’t use your PC as the USB-Host to supply the electrical power, otherwise it will fail to activate Multi-Boot!"

plz wait ! many new images for vim3l cooming soon !!
i will try to do it on the next week
ubuntu coreelec volumio openwrt …

3 Likes

@RDFTKV your test is for VIM3. I have VIM3L which requires different boot firmware.

Also, unfortunately, all of the flashing instructions imply an already working bootloader in eMMC, which is not the case for me, so none of this will work.

Yes I have VIM3, I was just pointing out that balbes150’s Armbian images for booting from SD should also work on the VIM3L after configuring uEnv.ini with the proper dtb, it has a dtb for VIM3L.

Have you tried using MASKROM mode for flashing? There are a variety of ways to get the board in to upgrade mode.

You may also want to try erasing the eMMC(All data will be lost) prior to flash attempt.
Good luck.

The armbian images will only work if there’s a working bootloader, and in my case there is not.

The eMMC on my board is already erased, so the mask ROM boots into USB mode. Unfortunately, none of the PC tools are detecting the board over USB, so I’m kinda stuck with only the ability to boot via SD images.

regarding this warning - how should the VIM3L board be powered for image burning, anybody? What are the powering options other than USB-C, that must be used for burning? Did not find any on-board power connector as VIM1 has.

I had the same question, especially because this says TBD: https://docs.khadas.com/vim3/ExtraPowerInput.html

That warning does not apply to flashing firmware using the USB Burning Tool. That warning applies when attempting to boot/run an OS from SD card or USB attached storage. It is necessary for the activation of multi-boot, which allows OSes to run from card or USB drive.
When flashing using USB Burning Tool, USB-C on VIMs must be connected to PC’s USB, the VIMs will take their power from the PC’s USB port during flashing.

I have edited my previous post for clarity.