VIM3L dead, no power LED

I’ve tried to load this image on VIM3L from SD card. After power supply disconnect I’m unable to power on board.

Situation like a that:

  • no power (white) LED
  • SBC does not boot from SD nor eMMC card
  • “upgrade mode” does not work

hello. is there any voltage missing?

I think it’s not problem with power supply, I’m tried different ones, but nothing happens

try to flash vim3 through computer, use usb burning tools,any official look image Khadas

No result, process freezes for few seconds, after it returns “Amlogic device not found” error

Open UBT, plug in vim3, quickly press the middle button 3 times.

Yes, I already did it, but useless, pc still recognize board as “Amlogic, Inc. GX-CHIP” device, that doesn’t respond to any command

It doesn’t matter, you must do it before installing the official image.

Thanks, but it’s not helpful, for now sbc does not boot from SD nor from eMMC
seems hardware is broken, if it is I will ask for refund

Just out of curiosity, did you try a different USB-C cable? You know sometimes a faulty cable will cause such intermittent and frustrating errors.


Can the original firmware on eMMC run?

Have you try TST mode ?