VIM3 with Ubuntu bionic + Touch screen TS050

I never asked for dual display function :frowning:

I just want to start testing only touchscreen display with vim3 and i have tried both as per that thread.
Ubuntu doesn’t display anything while Android only displays the khadas logo which is stretched as shown in that video.
Others have reported that it works but not working for me. What can be the issue?

The Link you recommended above is for egde and not vim3.

No update on making touchscreen work on vim3?

Touchscreen already supported.

1 Like

How about the LCD Driver for TS050 on Vim3 ?

Please check here:

1 Like

Hello Dear,
Thank you for the Links.
I have gone through the Touchscreen Link and it looks like I can add it to the kernel and the dts.

But the LCD one is little complicated for me to understand with my limit knowledge of kernel development. The reason is there is a separate amlogic directory maintained in your BSP which differs from the mainline directories.

I am not sure about the following files and the changed you have done to them. As these files are not present in the mainline and also no such directory is there.

  • aml_bl.h
  • aml_bl.c
  • lcd_vout.h
  • lcd_vout.c
  • lcd_common.h
  • lcd_common.c

If someone can advice me on how to add these to the mainline kernel then I can try it myself. I have forked @balbes150 git branch as we have mostly everything working on that built.

Yes, the LCD can only work on Amlogic 4.9 kernel.

There is no MIPI DSI support on mainline kernel for current stage.

You can check here:

1 Like

Ok. Do you have any rom with full ts050 support for Vim3 ?

Only single display for current stage.



And update to latest kernel:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sync
$ sudo reboot

Note: Remove the HDMI cable, if you want to use the panel.

1 Like

This didnt help with display or touch screen.

This did but still not usable. As the screen is scattered and torn.
Will upload a video to better understanding.

Please check this.

Seems not… @Terry is working on the Android Dual display now… will release new image when it is OK.

Can you try the V190830 image without any update ? V20190830 image already support the screen.

You can check here:


I checked , the screen and TP works.

EDIT again

When I do apt-get update && apt-get upgrade based on V190830, the screen also works.

You need to remove the HDMI cable, if you want to use the screen.

I didn’t use hdmi cable when i connect ts050. So i think there is some problem with the screen.

The screen with ubuntu without update just shows me khadas logo stretched and nothing else. I also tried the white cable as well as the black one.
I don’t know what is the problem then.

Make sure, you flash the right image:

After flash the image, please try the following things, remove the SD card and USB storage, make sure it boots from the eMMC.

Provide the information to me:

  • dmesg kernel log
  • cat /etc/fenix-release


Here is the uart log from Android.
Pastebin There might be somethings missing in this as the audit keeps spamming.
The above is when I connect only TS050 to Vim3.

Here is Linux 4.9 without the update on TS050 without hdmi connecting.

From the log, I don’t think you use the right image.

Your kernel information, It’s NOT V190830 release.

[    0.000000] Linux version 4.9.186 (khadas@d27a8e5af0df) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #12 SMP PREEMPT Tue Aug 13 11:06:23 CST 2019

The correct kernel information should be:

[    0.000000@0] Linux version 4.9.190 (khadas@d27a8e5af0df) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #51 SMP PREEMPT Fri Aug 30 11:44:18 CST 2019

And the release information:

root@Khadas:~# cat /etc/fenix-release 

Can you try the right image ?

Sure trying this tonight. What about the Android pie V191101 logs I shared above which doesn’t respond at all on ts050.

I will try and get back to you. Thanks for the support

Ignore this version, there is no LCD support. Will release the dual screen image next time for Android.


Hey. Thanks for the correct version.

Its working fine now. I will test it and then try to port the drivers to mainline, If I can.
Just to inform you. I tried to run kodi on ts050 and it doesnt seem to display anything can just see the blurred cursor. Also is there anyway to rotate the display and use it in landscape?

1 Like

Kodi can’t work with the LCD, seems related to the resolution…

It’s very easy for mainline kernel to rotate the display. But for 4.9, I haven’t find a way to do this for Desktop…(no drm support)

The Android Firmware support the TS050 now.