VIM3 white led blinking

Which Khadas SBC do you use?

VIM3 Pro, V14 22092247

Which system do you use? Android, Ubuntu, OOWOW or others?

Delete default android to switch Linux

Which version of system do you use? Khadas official images, self built images, or others?


Please describe your issue below:

I booted VIM3 Pro with the image above on SD Card, successfully, then installed listed ubuntu server image newest version on eMMC. eMMC boot failed at initial boot, then while led blinking started. The same SD Card reboot trial also failed. Any procedure does not work effectively.

I tried those procedures written on this page below.

TST mode : does not work
Key mode : does not work
Serial mode : cable was connected, some characters appeared on minicom terminal, but blinking like white led even after correct baud rate setting.
MRegister Mode : ‘two pads’ are not recognized on the board. Where are ‘two pads’ like two pads bellow power button.


Post a console log of your issue below:


Please let me show right URL or procedure for recovery. I will follow willingly.
I am seeing while led blinking with power on. It is very expensive led light. I am very disappointed with this failure.


@frail_wanderer You can install the image directly to eMMC also.

use the TST mode to enter upgrade more and by this utility method, you can install the Ubuntu image directly onto the eMMC.

Hello Electr1,

Thank you for reply. As I mentioned above. TST failed and do not work as below…

  1. Connect VIM3 to PC with a USB-C cable. → OK, White LED starts blinking after cable connected. I do not think this is you call ‘heartbeat’. USB-C cable is what I use for USB hard-drive connection to PC.

  2. Quickly press the Function key 3 times in 2 seconds, then release the key. You will see the Power LED (Blue) blink for about 3 seconds. —> No. I do not see this LED(BLUE) blink, still white LED blinking.

  3. After the Power LED (Red) turns OFF, this indicates that the board is in Upgrade Mode (Maskrom Mode). —> I never see this ‘Power LED (Red) turns OFF’, still white LED blinking.

By the way, I also tried USB_burn_tool with Windows 11 Desktop. This tool recognizes the image which I want to install to eMMC, but connection to VIM3 does not show up. Nothing happening. So I am writing on this forum. Please let me know effective procedure.

Please remove the SD card and try TST mode again.

Thank you. I followed your suggestion.

press the Function key 3 times in 2 seconds, w/o SD Card.

I did it very QUICKLY, faster “in 2 seconds”, then saw LED comes differently, turned BLUE then WHITE for a while and then likely WHITE heartbeat. Everything is fine! Display shows usual CUI prompt interface.

Thank you again for helpful advice.

Okay, if you want to flash the image to eMMC then you need to connect the board to your PC and try TST mode.

I made an Armbian boot SD Card by the image of this site.

Boot by SD Card at first then “armbian-install” to install eMMC. It worked.
My Khadas VIM3 LED starts with white LED blinking at USB-C power cable connect, then push function button 3 times bring to boot Linux. Something strange, but it works.