Vim3 stopped working

Hi Support…
I got my VIM3 and it worked really well for a few days… I put ubuntu on it and was compiling some code… However the power supply came off by accident and now the VIM3 wont start… The lights would not come on at all… I also was not using a heat sink or fan…

Any help would be greatly appreciated

Hello! change the cable or the power supply itself

HI Vladimir…

But i have tried several different power sources…
could it have died because it over heated?

But was the cable the same or another?

ive tried replacing both…

the power supply and cable are working, right?

yea its my own power supply… i use it to charge my phone… and it still charges my phone fine… Ive also tried using another supply and cable…

Does the LED display some kind of light on the board?

ok, make sure it works up to 12 Volts 3 Amps!

@darthShana I am sorry to hear this happened,
Which ROM are you using SD-USB or eMMC ?

im using a eMMC
ive tried insert the sd card which i use to install ubuntu… but it looks like the VIM3 wont power on at all…
Im using the same power source that used to work.

about the LED on the board, give information whether it is lit or not

here is what I can speculate,

Since you were using the device before it was “unpowered”, I Assume the internal eMMC could have been corrupted, Try to reflash the ROM and see if it solves the problem,

no LED are off… they do nothing when the power is connected of when i press the power button… They used to work, before the device was working

but the LED are not working… Could it be ROM issue?

It could be, I have had similar corruptions with SD card, if it is suddenly “unpowered”

Also you say you were doing compiling, which means the eMMC should have been working to do those Reads and Writes, so there is good chance that corruption could have happened,

@darthShana don’t worry about overheating, VIM3’s thermal profile, allows it to be under medium amount of stress without throttling, so unless some short circuit happened, which could be fatal

hmm but i inserted the sd card with Krescue and nothing happens. So i dont think i can flash it

you need to check whether power is supplied to the board or not

the SD card won’t boot right off the bat, you need to enter upgrade mode for it to boot

Please try to flash the board, via USB-C method first,
you can follow this guide, try Android for safety first then continue back with ubuntu.

Hmm so i have used 2 different cables and supplies both used to work fine on the vim3… And both continue to work on other devices… Is their any way for me to check if the hardware is broken?