VIM3 Pro Reboot

I recently bought a new VIM3 Pro. It appears to be defective out-of-the-box. It keeps rebooting after a short time or dies. I tried booting Ubuntu from a microSD card and can’t get a keyboard and mouse to work. Attempting to pair an Xbox controller via Bluetooth in Android also does not work.

1.what is your power supply?
2. do you have a cooling radiator?

Hello @DavidS, I am sorry to hear that you VIM3 has such a problem,
Some of problems look like a Power related issue,
Try using a better power supply, 10W (5v 2A) and above should work,

Also try placing the VIM3 on top of the Included box as a sort of insulation, don’t place it on tabletop or other surface, Try to get a case for it as soon as possible, It might lead to short circuit and ESD problems in the Near Future.

Also state The exact Ubuntu version you have used, some of our users also face such such problem with the headless version of Ubuntu (Server), is it Bionic or Focal, is the uboot 4.9 or 5.x version,
if possible please share the link to the ROM which you have used.

It will be more easier for us to pinpoint the source of Error, Thank you

I’m using the official 24W adapter; I don’t have a case for the VIM3 yet (waiting on access to a 3D printer for that), so I was keeping it on top of the box with the heatsink. I also experimented without. Counter-intuitively, it seems to work best under load, for example, if I get far enough to play a video.

ROM Link:

what is the temperature during reboot?

Try a newer firmware, it should work, I have also had problems there too.
when it dies, try pressing the power button again and see if it reboots back or comes back on to its previous state,
what is the color of the LEDs on the board during those situations?

I am having some 3D designs coming up, would like to be my tester for the designs once you get your printer ? :slight_smile:

do a test of maximum processor load to exclude the option with heating

Hello, As stated, the reboots/shutdowns are often power related. Even though you are using the official Khadas 24W PS, I would still try an alternate just to rule out power as an issue. Also try a different power cable(USB-C).
The mouse and keyboard issues are likely related to firmware/uboot, etc, workarounds exist.
For now, I would focus on the reboot/shutdown issue.

1 Like

I tried it again with the 18W charger for my Honor 8 and a different USB cable. I installed a CPU Load Generator app and got to 75-80% utilization. Temperature was up to 71 °C. No issues.

Will work on Linux ROMs next.


yes, look with other OS how it will work

1 Like

That’s good to hear :slight_smile: , definitely not a hardware problem, please continue testing with linux just to be double sure