Vim3 Pro not powering on?

Which Khadas SBC do you use?

Vim3 Pro

Which system do you use? Android, Ubuntu, OOWOW or others?

Android 9 pie or Ubuntu

Which version of system do you use? Khadas official images, self built images, or others?

Khadas official Images

Please describe your issue below:

i recently flashed android 12 aosp rom from khadas server, after that my vim3 pro is no longer working with any usb c power adapter? it doesn’t power on? no led’s light up? but powers on only when connected to computer usb port that too with all vim3 pro usb ports disabled?
so it is not possible to use my vim3 pro anymore, without any keyboard or mouse? but i can flash roms on it using computer, i have tried flashing different android and linux roms from khadas website, but nothing is helping? still facing the same issues described above?
is it a hardware or software fault? please help me urgently ASAP, since i cannot use my vim3 pro anymore!

@giriraj7 After you flash Khadas official Android 9 firmware, plug in the USB-C power supply, does HDMI have output? Normally, you can use the port of the computer to supply power, but it is also possible to use an external power supply. Also, do you have a serial port tool?

Hello Frank,
No matter what firmware (even krescue) i try, i get no hdmi output, no led’s light up (white, red or blue) when i plug in USB-C power supply, but when i connect it to computer usb port (usbA to usbC cable) everything works normally except usb ports on Vim3 pro don’t function, so i cannot use mouse, keyboard or my touchscreen display? No, i don’t have any serial port tool!
Can you figure out whether it is hardware or software issue?

If you’re using a USB c power supply with a USB c to usb c cable then ive found it doesn’t work - try a different power supply with a USB A output or a usb a to usb cable and a usb a to c converter in the usb c power supply - expect it will work then

New update! I have usb tester at home and connected it to vim3 pro usb ports (while connected to computer by usbA to usbC cable) to find that they are not dead but undervolted? Reads about 4.7V instead of normal 5V with computer usb ports? That confirms it’s most likely a hardware issue!

Hello birty,
Before i upgraded to android 12 aosp, vim3 pro used to work every time whether connected to khadas official power adapter (usbC to usbC cable) or computer usb ports (usbA to usbC cable)? It didn’t matter which usb cable or port (typeA or typeC) used? Now it only works with usbA to usbC cable, with vim3 pro usb ports undervolted? So i cannot use any usb device, keyboard, mouse or touchscreen input? No way to operate Vim3 pro?

@giriraj7 Please use 12V power supply, 5V is not enough to drive VIM3 to work normally.

I had tried using khadas official power adapter that supplies 5V3A to 9V2.67A to 12V2A (usbC to usbC cable) vim3 pro doesn’t power on at all?

@giriraj7 Record a video of you plugging in the 12V official power supply, let’s see what the state of the board is

i have made videos, but how do i upload them?

@giriraj7 Maybe yotube? Google Cloud Drive ?

These are the links to videos! Hope these clarify everything!

Please check the links i posted! I have already tested official khadas power adapter and usbC to usbC cable with usb tester, they are fine! I have even tried other usb c power adapter (came with my portable 4k touch display) 30W again 12V with power delivery with it’s own usbC to usbC cable, again vim3 doesn’t power on and display works fine with it?

New update: I tested Vim3 pro again with my 4K portable display and power bank!
This is what happens when vim3 pro is connected to power bank usbC port with usbC to UsbC cable!

Now this is what happens when i connect vim3 pro to power bank using usbA to usbC cable!

Please note that now i am using official android 9 pi rom from khadas server!

Again, no touchscreen input, keyboard, mouse or usb pen drives working? Also, you can notice
usb voltage on usb tester? I have never seen such low usb voltage before?

I have used vim3 pro like this before (with power bank and my portable 4K display) since last six months flawlessly even with usb pen drives or usb hdd (Power bank can output 30W power with power delivery) and watched 4K HDR 60Hz movies and videos without any problems!

But I am totally disappointed now that vim3 pro didn’t last more than six months (actual usage) and I wasted 200USD on it?

I have just checked on internet all major resellers like ameriDroid offer one year warranty on purchase of vim3 pro, but i purchased directly from Khadas,

can i get my product replaced under warranty? I am attaching purchase order receipt!


Sorry, that was because of an unknown setting! I fixed that now! Please try opening the links now! Have you seen the photos?

Your meter shows 4.68 Volts.
Why is it so low?