Vim3 pro no display

I cannot see the usual boot screen and i confirmed its not cable or monitor issue, not sure if its a hw issue but i have no display. My emmc is loaded with android and it usually boots fine.

Now when i power on, screen is black and led white and red remains lit.
i also tried flashing android with usb burning tool again, everything can be completed but again no display.

What should i do?

Hello, How are you powering the VIM3? Power supply of 5volts and 2 amps or better recommended.

Push the HDMI and power leads in as hard as you can. This fixed the problem for me and others :wink:

How about the issue?

Have you ever use the other monitor?

still the same. it looks like hardware issue to me, it just gave up suddenly. My VIM3pro has been using the same cables, monitor with no issues, even if i use on tv. hdmi cable and monitor confirmed still works with pi3/pi4 and odroid. Now, i even tried another monitor, tvs. All no display, except white/red LED lit on board.

i reached out to support, they asked me to post here on forum. Please let me know if i can ship back to you for investigation.

i have been using this vim3pro since Sep 2019. In fact khadas shipped a v11 unit instead of the production v12. Anyway, i am using a 30w usb c charger. I tried 45w 60w with 3A/5A cable still same no display.

I’m using normal pressure for fear of damaging the connectors, esp hdmi/usb c connector are so close, certain cables with connectors are pushing connectors apart.

Exactly! The VIM3 / Pro is a great device but the connector ports are pretty cramped. It was only after reporting some issues over at the CoreELEC forum (that I presumed were software related) and being advised that similar issues, with these devices, had turned out to be due to bad connections, that I paid extra attention to this and, for me too, this proved to be the culprit. :+1:

1 Like

If your HDMI output has been working normally since 2019 and then spontaneously stopped working, it is likely that your HDMI output has died (this is a common problem for the s922x).

Poida’s advice is correct.

Also i swapped out the USB C cable with my Xiaomi Mi A1 phone cable which is slightly smaller. Works a treat.
I plug and unplug the Vim3 all the time due to testing CE and it is the first few times it’s tight. I forgot about the first time it was not easily inserted. I copped the same issue as yourself.

@Terry i can’t use the HDMI now. Please let me know if i should contact the support guys. I tried everything including pushing hdmi cable inward but the HDMI connector is rock solid.

Sorry for reply you so late. Can you provide the booting log for me? And I will let our sales contact you after I check the log.

If this is true then I am facing the same issue :frowning:

My Vim3-Pro was working just fine and I was compiling some packages and then my screen started flickering heavily so I thought my screen is dying.

But after reboot and trying some other boards and HDMI cable I see that my screen and the cable is fine, only Vim3 is not able to give any output over HDMI.

@numbqq or anyone from Khadas team advice on this ?
My bootlog here.
Kernel is able to detect the hdmi tx controller but no output at all.

Ohhh snap, are you sure that your port has no physical damage right ?

Good point but I doubt that is possible as it is well fitted inside the case and when it stopped working I didn’t even remove the hdmi for several days so it have been working since then.
Thanks for asking though.

Hmm, how is such a thing even possible ?, I Have no why of referencing to this because I run Mine Headless most of the time, the maximum it has even been connected to a HDMI display is 3 hours at max, through its entire life, If it is such a plaguing problem, why has this not been addressed yet?

Is this just HDMI port or Video output itself, can you verify the video output on your touchscreen ?

@Vladimir.v.v I think the problem is related at the root of the device, the bare silicon that’s running the display output, this is a design problem related to the chip itself.

Maybe bad TTL circuitry ?, there is no way of knowing unless you can observe the Physical CPU die for this…

1 Like

ok, then the problem will be initially, isn’t it?

I do not mind, is there somewhere evidence on this subject or is it just someone said?

That someone is me :grin:
it is obvious, if HDMI does not work, but the port has no physical damage, it has to be traced to its root,
which is the Video controller in this case…