VIM3 not booting from eMMC


I just received a VIM3 4Gb, I tried to Upgrade via USB-C cable according with
the instruction at this link
I am using Windows 7 operative system and all the steps (1 to 4) were successing.

I flashed the “VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20191231.img”
I tried to power VIM3 with a socket power supply of 5v 1.35A, but nothing happened just the white led went on, then I tried with a power supply of 5V 10A still nothing happened just the white led went on.
I was expecting VIM3 to boot Ubuntu, but on the video I see nothing at all.

I did another trial and flashed an older image
same result.


judging by the picture, loading in eMMC is correct! need to look further, HDMI, power supply, monitor

@RiccardoRM Did you have a serial tools ? You can check the board boot log via serial tools .

Hello, A 5v 2 amp or better PS is recommended. It may boot with 1.35a, depending on what connected USB devices are used, but more amps would be desirable.

what is a serial tool ?

I am using a monitor with multiple input HDMI / DVI-D , it is my main video, DVI-D is conneted to my home computer, and HDMI conneted , depending of the needs, to raspberry pi / Khadas.
HDMI is working correctly if I connect raspberry I see what raspberry is sending, if I connect Khadas the screen is completely black (no sign of activity at all).

Please read carefully what I wrote, I tried a 5V 10A also and no activity at all.

Yes, an oversight. My apologies.

@RiccardoRM This one

try flashing through Krescue, before doing this, eMMC clean through the same Krescue