[VIM3] HDMI glitches with mainline u-boot

Greetings everyone,

I’ve just recently faced a weird issue after updating old vendor uboot to new mainline (khadas-patched, I presume) version via Kresque. I’ve tried both
and VIMx.UBOOT.mainline.emmc.kresq, effect is the same.
In two words: the HDMI output seems to be glitching. I see a double green line on the left border of the screen and some colors are fuzzy (doubling?). Also, in graphics mode X11, the screen randomly blinks once in a while, may be every 2-3 minutes or so. That was not the case with the old uboot but it was working with the 4.9.x android kernel, and everything was perfect. I also tried 5.7 and 5.9 versions of the kernel and all is the same. I’m attaching a photo from the screen showing the color issue, it’s from the plain linux console, but in X11 it’s the same. I was hoping may be somebody has already found out what is the root cause of the issue and could help me solve it.
Thanks in advance.

It seems the color glitch is due to the mainline kernel. The old 5.7.0 built by manjaro doesn’t have this glitch (although it still randomly blinks in X11), whereas fresh ones 5.7.14 and 5.8.x have.