VIM3 Firmware upgrading - no mouse and keyboard

It only happens with VIM3 mainline kernel with PCIe enabled but NVMe SSD removed, 4.9 kernel works well.

@mouacyk @jiapei100

Here is the new image with PCIe disabled, the USB should work.


thank you, it works now

Still the same from my side…
mouse and keyboard are still locked…

How you bootup the mainline image? Have you erased the eMMC?

longervision-GT72-6QE% sudo dd bs=4M if=VIM3_Ubuntu-xfce-bionic_Linux-5.5-rc2_arm64_SD-USB_V0.8.2-20200103.img of=/dev/mmcblk0 conv=fsync
[sudo] password for longervision: 
1093+0 records in
1093+0 records out
4584374272 bytes (4.6 GB, 4.3 GiB) copied, 200.589 s, 22.9 MB/s

I ONLY burned TF so far…

Please check the release note:

NOTE: For mainline image, DO NOT use verdor u-boot to boot it, you need to erase the eMMC and fully boot from the SD card or you will get a green screen.

  1. It seems mine is khadas pro, and there is an existing Ubuntu on it. I’m using it temporarily for now…
  2. I actually tried to press P+F for a long term (without TF card inserted) after rebooting, it’s NOT working …
  3. Some times, the rebooting process recursively occurs, without letting me log in… I guess Khadas is easily to get overheating ???

Can confirm, VIM3 arribed friday and today I installed VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20191231 and mouse and keyboard don’t work. Will try the SD version tomorrow.

I think these post already answers the reason for USB not working, You need to change the mode using Krescue.

It’s impossible that USB doesn’t work on 4.9 kenel.

@Spikerguy thanks, sorry wasn’t aware of that will try Krescue.

The keyboard worked to log in once Ubuntu starts up and asks for password for Khadas user, the mouse doesn’t work. When you log in neither the keyboard or mouse work (I’m not using a hub for mouse+keyboard, they are plugged in both USBs). Will try disabling PCIe and seeing if it works.

I will check usb mouse kbd soon;)

Thanks :slight_smile:

I’ve ALREADY tried two ways to erase eMMC, as described .

  1. Keys Mode (Side-Buttons)
  2. CLI Mode

I NEVER plug in a TF card for these 2 methods, but both methods end up rebooting khadas up, with a khadas login dialog.

It’s good to have 32G eMMC so that people may NOT need an extra TF card for this particular board. But, TF card is some times required… Any progress on this issue?

Furthermore. After sudo apt upgrade all packages, current khadas monitor’s background seems weird. The color is NOT smooth at all. It looks to me the WRONG RGB. Any suggestions?


Try the interrupt method to clear eMMC.

1 Like

Hello, I am having the same problem, both USB ports are disabled but only with ubuntu, android is not affected and the interface are in USB3.0 mode. The kernel seems to be disabling the ports expressly. Any idea what could be happening?

root@Khadas:~# dmesg
[   33.760749] USB_PWR: disabling

root@Khadas:~# cat /sys/class/mcu/usb_pcie_switch_mode

root@Khadas:~# cat /etc/fenix-release 

root@Khadas:~# cat /etc/lsb-release 
1 Like

Hi all!
I got the same problem after EMMC android was updated to latest ( VIM3_Pie_V200103) version.
For me the problem was successfully resolved by erasing EMMC
dd if=/dev/zefo of=/dev/mmcblk2 bs=512 count 32767.
Also it has resolved ‘pink screen’ problem absolutely the same as: Ubuntu issue creating too much conrast on display

Now dmesg seems as:
3.115954] USB_PWR: supplied by VCC_5V

Keybord/mouse works perfect.
The colours are also correct.

root@Khadas:~# uname -r
1 Like

dd if=/dev/zero count=666 > /dev/mmcblk2 - this one more correctly :wink:
or more more correctly there =>

1 Like

Thx, didn’t knew that, I just counted the same amount of sectors as before 1st partition on SD.