VIM3 Armbian image?

Information changes quickly, and this is an extra task for syncing.

These instructions are ambiguous and very hard to understand because they are very poorly translated.

1 Like

an up to’date debian distro than can be directly installed from cloud to emmc would be the best for me and for those who like to keep the installation process simple and elegant.
maybe armbian goals are different? at the end , it is the end user that takes the decision and makes the choice

1 Like

please be more precise and detailled regarding those questionnable and obscure additions !

I am still trying to figure out why i can’t boot armbian images in my Vim3, vim1 images boot up with no problem, manjaro and official vim3 images also boot, only armbian is causing problems.

I always change dtb to vim3(a311), @numbqq, @Gouwa, @tsangyoujun, @hyphop, can you check what could be the issue?

For armbian you need to tag @balbes150.

I checked Armbian_20.02.0-rc1.038_Aml-s9xxx_bullseye_current_5.5.0-rc6_20200205.img on VIM3 and it bootup well.

You need to setup the dtb in uEnv.txt

--- uEnv.txt.orig       2020-03-20 02:02:54.000000000 +0000
+++ uEnv.txt    2020-03-20 02:03:08.000000000 +0000
@@ -16,5 +16,5 @@
 #APPEND=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyS0,115200 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0 mem=2048M video=HDMI-A-1:e
 # aml s9xxx
 APPEND=root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes net.ifnames=0

balbes150 has very good instructions here. Also may want to have a look at the section that covers color issues…
Fix for correct color to G12 (Amlogic S905X2 S922X), a simple edit to a file on the SD card.

it seems to me that the answer is here somewhere :penguin:

Read the instructions carefully, especially what is written at the end in red.

Because such an installation system is not able to perform the process correctly.

I’ve tried it few hundred times, i’ve read instructions about setting up everything few thousand times, and i still don’t understand what am i doing wrong, on vim1 everything works without a problem.

Can someone with working Armbian on Vim3 make a screenshot with uenv.ini settings, maybe that could help?

Btw, thanks everyone for help!

1 Like

Fully restore the standard Android firmware and do it via USB Burn Tool. Perform a clean activation of the universal multiload. Start with the s9xxx image (don’t change anything in it ). If you did everything correctly, you will at least appear at least something on the screen. After that, you can try making settings and using other generic images.


Can you post a screenshot of how the uenv.ini should look like, i’ve done now everything as you said, still the same thing.

Multiboot is activated if it runs manjaro from sd?

I believe i am not doing something good in uenv file, can’t figure out what, but i did the same thing on vim1, and it boots fine on vim1.

Have you restored the regular Android firmware ?

Yes, done everything as you said.

Which Armbian image do you use and which media ?

Armbian 20.05, image 11.03, sd card.

I’ve tried at least 5 or more of your images in the last few months, i can run them on Vim1, but on Vim3 nothing, i’ve even tried to boot them from 2-3 sd cards, usb flash drive, always the same result.

I know i am boring you, but i can’t figure out what am i doing wrong, manjaro boots without an issue, so i do believe i am doing something wrong.

I did even try to see if there is any video on youtube that shows the correct procedure, but all of the videos are outdated.

I received vim3 charger few days ago, and now i am on forced vacation that i’ll unfortunately spend at home because of the coronavirus (i don’t have it) , so i’d like to see how Armbian works on vim3.

If you use these images for the first check, you don 't need to change anything in them after recording. Important. Correctly activate the universal multi -upload. Connect the media , press the power button and hold it, turn on the power, press the reset button for 2 seconds and release the reset button (continuing to hold the power button for another 2-3 seconds). You should get at least some image on the screen. Only then can you proceed to the next configuration and use other (recent) images .

1 Like

I do have something weird to report, i forgot to mention that, when i hold the power button on Vim3, it looks like it’s not holding it, khadas logo image reappears again and again every few seconds, i am holding it and it should stay still.

@balbes150, we have a progress, this image booted up without any problem, i didn’t have to hold anything, so it means multiboot is activated and i am clearly not doing something well?