Vim3 apt repository broken

when trying to install packages from the apt repository I get the following error:

E: Failed to fetch File has unexpected size (8123224 != 8062936). Mirror sync in progress? [IP: 443]
Hashes of expected file:
- SHA256:f48fc229b1c8d153e335fdbedc9ffa93bb409c917d455b1b0598283029c1cc61
- SHA1:dc40fc183737ce514fc0f31fc5fb50be78fe224f [weak]
- MD5Sum:1e30ddcc77f4e63b60c228c0fa9b489f [weak]
- Filesize:8062936 [weak]


@dpmkl what firmware are you using, this looks like a problem of old firmware, use latest firmware (20.04 focal images -4.9 kernel), it will have it pre-installed for you :slight_smile:

The problem is that the repo contains two opencv packages.
The relevant one ( pool/main/o/opencv3/opencv3_3.4.3-2_arm64.deb)
is referenced from both focal and bionic:

However with different file sizes and hashes.
Practically this is a big problem for anybody who cannot, or does not want to, update to focal.

1 Like

Exactly, If you update to Focal your problems will be solved,
but for anyone using bionic, you will have problems installing it.

1 Like

Sorry to come back to this. But this plainly means that the repo is unusable for a LTS kernel version because the changed opencv dependency has library requirements that are not available for 18.04.

yep, I think that’s what I said before as well…

18.04 LTS has had its official support end just recently, so the only things coming out will be maintenance updates and stuff…

We can’t really control the compatibility of those software tools, we just have to be up to date to make sure everything works…, That is also what they expect…

I have got the same problem here, my installation is basicly broken, just because I updated …

18.04 LTS has had its official support end just recently,

This is NOT true, see for your self

so the only things coming out will be maintenance updates and stuff…

Correct, I should be able to update my system without braking it until at least 22.04

We can’t really control the compatibility of those software tools

That is what is expected of you, as a VENDOR!

If you don’t support bionic anymore, fine … but, please, at least have the decency to:

  1. Inform your (paying) customers about it, with enough time ahead to take action
  2. Remove the bionic repo so no one else breaks his system by “accident”

Hello @zerozero, I’m sorry mate, but I am not the Vendor, I am just a Forum user,
If you want you can ask Khadas themselves to remove it, but it has just been kept there for anyone who wants to go back to it for testing or something…

generally it is a rule of thumb to keep your software components as up to date as possible,

don’t worry about your device, it can be fixed easily,
If you have a windows PC you can either use the USB burn tool, or Krescue to restore to its former state

Hello @fisfsw @zerozero @dpmkl

Sorry for the trouble, I wii check this issue.

1 Like

Hello @fisfsw @zerozero @dpmkl

Can you tell me how to reproduce this issue ?

Which image you used to test ?

I checked VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20191231.img
on my side, it seems work well. I tried sudo apt-get update && sudo apt-get install sl && sudo apt-get upgrade.

Check the log here:

khadas@Khadas:~$ date
Fri Jul 31 01:56:53 UTC 2020
khadas@Khadas:~$ sudo apt-get update
[sudo] password for khadas: 
Hit:1 bionic InRelease                        
Get:3 bionic InRelease [2,196 B]              
Get:5 bionic/main arm64 Packages [9,831 B]
Get:7 bionic/main armhf Packages [2,135 B]
Get:2 bionic-security InRelease [88.7 kB]
Get:4 bionic-updates InRelease [88.7 kB]
Get:6 bionic-backports InRelease [74.6 kB]
Get:8 bionic-security/main armhf Packages [575 kB]
Get:9 bionic-security/main arm64 Packages [644 kB]
Get:10 bionic-security/restricted arm64 Packages [895 B]
Get:11 bionic-security/restricted armhf Packages [5,504 B]
Get:12 bionic-security/universe armhf Packages [704 kB]
Get:13 bionic-security/universe arm64 Packages [772 kB]
Get:14 bionic-security/multiverse armhf Packages [1,849 B]
Get:15 bionic-updates/main armhf Packages [843 kB]
Get:16 bionic-updates/main arm64 Packages [918 kB]
Get:17 bionic-updates/restricted arm64 Packages [1,341 B]
Get:18 bionic-updates/restricted armhf Packages [11.1 kB]
Get:19 bionic-updates/universe armhf Packages [1,177 kB]
Get:20 bionic-updates/universe arm64 Packages [1,252 kB]
Get:21 bionic-updates/multiverse arm64 Packages [3,915 B]
Get:22 bionic-updates/multiverse armhf Packages [4,837 B]
Get:23 bionic-backports/main arm64 Packages [8,260 B]
Get:24 bionic-backports/main armhf Packages [8,247 B]
Get:25 bionic-backports/universe armhf Packages [8,101 B]
Get:26 bionic-backports/universe arm64 Packages [8,104 B]
Fetched 7,213 kB in 6s (1,289 kB/s)                     
Reading package lists... Done
khadas@Khadas:~$ sudo apt-get install sl
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 198 not upgraded.
Need to get 25.5 kB of archives.
After this operation, 96.3 kB of additional disk space will be used.
Get:1 bionic/universe arm64 sl arm64 3.03-17build2 [25.5 kB]
Fetched 25.5 kB in 1s (26.3 kB/s)
Selecting previously unselected package sl.
(Reading database ... 71183 files and directories currently installed.)
Preparing to unpack .../sl_3.03-17build2_arm64.deb ...
Unpacking sl (3.03-17build2) ...
Setting up sl (3.03-17build2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
khadas@Khadas:~$ cat /etc/fenix-release 
khadas@Khadas:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  edid-decode gstreamer-aml libcec4 libgl1-mesa-dri
The following packages will be upgraded:
  aml-npu apt apt-transport-https apt-utils base-files bind9-host binutils
  binutils-aarch64-linux-gnu binutils-common bluetooth bluez bsdutils
  ca-certificates cpp-7 curl dbus distro-info-data dmsetup dnsutils e2fsprogs
  fdisk file g++-7 gcc-7 gcc-7-base gcc-8-base gcc-8-base:armhf git git-man
  glib-networking glib-networking-common glib-networking-services iproute2
  kmod libapt-inst2.0 libapt-pkg5.0 libasan4 libasound2 libasound2-data
  libatomic1 libavcodec57 libavfilter6 libavformat57 libavresample3
  libavutil55 libbind9-160 libbinutils libblkid1 libbluetooth3 libbsd0
  libc-bin libc-dev-bin libc6 libc6:armhf libc6-dev libcc1-0 libcom-err2
  libcomerr2 libcups2 libcurl3-gnutls libcurl4 libdbus-1-3 libdbus-1-dev
  libdevmapper1.02.1 libdns-export1100 libdns1100 libdrm-amdgpu1 libdrm-common
  libdrm-etnaviv1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl-mesa0
  libext2fs2 libfdisk1 libgbm1 libgcc-7-dev libgcc1 libgcc1:armhf libgcrypt20
  libgfortran4 libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-data
  libglx-mesa0 libgnutls30 libgomp1 libicu60 libirs160 libisc-export169
  libisc169 libisccc160 libisccfg160 libitm1 libjpeg-turbo8 libjson-c3
  libjson-glib-1.0-0 libjson-glib-1.0-common libkmod2 libldap-2.4-2
  libldap-common libllvm8 liblsan0 liblwres160 libmagic-mgc libmagic1
  libmount1 libmysqlclient20 libnm0 libnss-myhostname libnss-systemd libobjc4
  libopenexr22 libpam-systemd libpostproc54 libpq5 libpulse0 libpython2.7
  libpython2.7-minimal libpython2.7-stdlib libpython3.6 libpython3.6-minimal
  libpython3.6-stdlib librsvg2-2 librsvg2-common libsasl2-2
  libsasl2-modules-db libseccomp2 libsmartcols1 libsmbclient libsqlite3-0
  libss2 libssh-gcrypt-4 libssl-dev libssl1.1 libstdc++-7-dev libstdc++6
  libswresample2 libswscale4 libsystemd0 libtsan0 libubsan0 libudev1 libuuid1
  libwayland-client0 libwayland-cursor0 libwayland-egl1 libwayland-server0
  libwbclient0 libxau6 libxml2 linux-base linux-board-package-bionic-vim3
  linux-dtb-amlogic-4.9 linux-gpu-mali-fbdev linux-headers-amlogic-4.9
  linux-image-amlogic-4.9 linux-libc-dev linux-u-boot-vim3-vendor locales
  mount multiarch-support network-manager nplan openssl python-apt-common
  python-pil python2.7 python2.7-minimal python3-apt
  python3-software-properties python3.6 python3.6-minimal rfkill rsync
  samba-libs software-properties-common sudo sysstat systemd systemd-sysv
  tzdata u-boot-tools ubuntu-minimal udev unattended-upgrades util-linux vim
  vim-common vim-runtime vim-tiny xxd
193 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 158 MB of archives.
After this operation, 6,155 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 bionic-security/main arm64 libgomp1 arm64 8.4.0-1ubuntu1~18.04 [69.7 kB]
Get:2 bionic/main arm64 aml-npu arm64 [3,318 kB]
Get:3 bionic-security/main armhf gcc-8-base armhf 8.4.0-1ubuntu1~18.04 [18.8 kB]
Get:4 bionic-security/main arm64 gcc-8-base arm64 8.4.0-1ubuntu1~18.04 [18.8 kB]
Get:5 bionic-security/main arm64 libgcc1 arm64 1:8.4.0-1ubuntu1~18.04 [34.4 kB]
Get:6 bionic-security/main armhf libgcc1 armhf 1:8.4.0-1ubuntu1~18.04 [37.1 kB]
Get:7 bionic-security/main arm64 libitm1 arm64 8.4.0-1ubuntu1~18.04 [24.3 kB]
Get:8 bionic-security/main arm64 libstdc++6 arm64 8.4.0-1ubuntu1~18.04 [372 kB]
Get:9 bionic-security/main arm64 liblsan0 arm64 8.4.0-1ubuntu1~18.04 [121 kB]
Get:10 bionic-security/main arm64 libtsan0 arm64 8.4.0-1ubuntu1~18.04 [269 kB]
Get:11 bionic-security/main arm64 libobjc4 arm64 8.4.0-1ubuntu1~18.04 [38.9 kB]
Get:12 bionic-security/main arm64 libcc1-0 arm64 8.4.0-1ubuntu1~18.04 [36.5 kB]
Get:13 bionic-security/main arm64 libatomic1 arm64 8.4.0-1ubuntu1~18.04 [9,176 B]
Get:14 bionic-security/main arm64 libc-dev-bin arm64 2.27-3ubuntu1.2 [58.7 kB]
Get:15 bionic-security/main arm64 libc6-dev arm64 2.27-3ubuntu1.2 [2,049 kB]
Get:16 bionic-security/main armhf libc6 armhf 2.27-3ubuntu1.2 [2,207 kB]
Get:17 bionic/main arm64 linux-board-package-bionic-vim3 arm64 0.8.2 [1,440 kB]
Get:18 bionic-security/main arm64 libc6 arm64 2.27-3ubuntu1.2 [2,274 kB]
Get:19 bionic/main arm64 linux-dtb-amlogic-4.9 arm64 0.9 [35.7 kB]
Get:20 bionic/main arm64 linux-gpu-mali-fbdev arm64 0.9-r12p0 [11.9 MB]
Get:21 bionic-security/main arm64 linux-libc-dev arm64 4.15.0-112.113 [960 kB]
Get:22 bionic-updates/main arm64 base-files arm64 10.1ubuntu2.8 [59.7 kB]
Get:23 bionic-updates/main arm64 bsdutils arm64 1:2.31.1-0.4ubuntu3.6 [54.6 kB]
Get:24 bionic-security/main arm64 libext2fs2 arm64 1.44.1-1ubuntu1.3 [137 kB]
Get:25 bionic-security/main arm64 e2fsprogs arm64 1.44.1-1ubuntu1.3 [346 kB]
Get:26 bionic-updates/main arm64 libuuid1 arm64 2.31.1-0.4ubuntu3.6 [18.5 kB]
Get:27 bionic-updates/main arm64 libblkid1 arm64 2.31.1-0.4ubuntu3.6 [105 kB]
Get:28 bionic-updates/main arm64 libfdisk1 arm64 2.31.1-0.4ubuntu3.6 [138 kB]
Get:29 bionic-updates/main arm64 libmount1 arm64 2.31.1-0.4ubuntu3.6 [115 kB]
Get:30 bionic-updates/main arm64 libsmartcols1 arm64 2.31.1-0.4ubuntu3.6 [70.7 kB]
Get:31 bionic-updates/main arm64 fdisk arm64 2.31.1-0.4ubuntu3.6 [95.0 kB]
Get:32 bionic-updates/main arm64 util-linux arm64 2.31.1-0.4ubuntu3.6 [818 kB]
Get:33 bionic-security/main arm64 locales all 2.27-3ubuntu1.2 [3,603 kB]
Get:34 bionic-security/main arm64 libc-bin arm64 2.27-3ubuntu1.2 [475 kB]
Get:35 bionic-security/main arm64 bluez arm64 5.48-0ubuntu3.4 [772 kB]
Get:36 bionic-updates/main arm64 libsystemd0 arm64 237-3ubuntu10.41 [174 kB]
Get:37 bionic-updates/main arm64 libnss-myhostname arm64 237-3ubuntu10.41 [32.5 kB]
Get:38 bionic-updates/main arm64 libnss-systemd arm64 237-3ubuntu10.41 [89.9 kB]
Get:39 bionic-updates/main arm64 libpam-systemd arm64 237-3ubuntu10.41 [92.2 kB]
Get:40 bionic-updates/main arm64 systemd arm64 237-3ubuntu10.41 [2,560 kB]
Get:41 bionic/main arm64 linux-headers-amlogic-4.9 arm64 0.9 [10.8 MB]
Get:42 bionic-updates/main arm64 udev arm64 237-3ubuntu10.41 [1,049 kB]
Get:43 bionic-updates/main arm64 libudev1 arm64 237-3ubuntu10.41 [48.2 kB]
Get:44 bionic-security/main arm64 libdbus-1-dev arm64 1.12.2-1ubuntu1.2 [150 kB]
Get:45 bionic-security/main arm64 libdbus-1-3 arm64 1.12.2-1ubuntu1.2 [152 kB]
Get:46 bionic-security/main arm64 dbus arm64 1.12.2-1ubuntu1.2 [130 kB]
Get:47 bionic-security/main arm64 libglib2.0-0 arm64 2.56.4-0ubuntu0.18.04.6 [983 kB]
Get:48 bionic-updates/main arm64 kmod arm64 24-1ubuntu3.4 [78.2 kB]
Get:49 bionic-updates/main arm64 libkmod2 arm64 24-1ubuntu3.4 [32.7 kB]
Get:50 bionic-updates/main arm64 systemd-sysv arm64 237-3ubuntu10.41 [14.7 kB]
Get:51 bionic-updates/main arm64 mount arm64 2.31.1-0.4ubuntu3.6 [97.8 kB]
Get:52 bionic-security/main arm64 libapt-pkg5.0 arm64 1.6.12ubuntu0.1 [766 kB]
Get:53 bionic-security/main arm64 libapt-inst2.0 arm64 1.6.12ubuntu0.1 [53.8 kB]
Get:54 bionic-security/main arm64 apt arm64 1.6.12ubuntu0.1 [1,166 kB]
Get:55 bionic-security/main arm64 apt-utils arm64 1.6.12ubuntu0.1 [199 kB]
Get:56 bionic-updates/main arm64 libgnutls30 arm64 3.5.18-1ubuntu1.4 [541 kB]
Get:57 bionic-security/main arm64 libseccomp2 arm64 2.4.3-1ubuntu3.18.04.3 [37.0 kB]
Get:58 bionic-security/main arm64 libpython3.6 arm64 3.6.9-1~18.04ubuntu1.1 [1,306 kB]
Get:59 bionic-security/main arm64 libssl-dev arm64 1.1.1-1ubuntu2.1~18.04.6 [1,363 kB]
Get:60 bionic-security/main arm64 libssl1.1 arm64 1.1.1-1ubuntu2.1~18.04.6 [1,062 kB]
Get:61 bionic-security/main arm64 python3.6 arm64 3.6.9-1~18.04ubuntu1.1 [203 kB]
Get:62 bionic-security/main arm64 libpython3.6-stdlib arm64 3.6.9-1~18.04ubuntu1.1 [1,607 kB]
Get:63 bionic/main arm64 linux-image-amlogic-4.9 arm64 0.9 [12.3 MB]
Get:64 bionic-security/main arm64 python3.6-minimal arm64 3.6.9-1~18.04ubuntu1.1 [1,327 kB]
Get:65 bionic-security/main arm64 libpython3.6-minimal arm64 3.6.9-1~18.04ubuntu1.1 [528 kB]
Get:66 bionic-security/main arm64 libsqlite3-0 arm64 3.22.0-1ubuntu0.4 [430 kB]
Get:67 bionic-security/main arm64 libjpeg-turbo8 arm64 1.5.2-0ubuntu5.18.04.4 [91.5 kB]
Get:68 bionic-security/main arm64 libbsd0 arm64 0.8.7-1ubuntu0.1 [36.6 kB]
Get:69 bionic-security/main arm64 libsmbclient arm64 2:4.7.6+dfsg~ubuntu-0ubuntu2.17 [45.6 kB]
Get:70 bionic-security/main arm64 libcups2 arm64 2.2.7-1ubuntu2.8 [180 kB]
Get:71 bionic-security/main arm64 libsasl2-modules-db arm64 2.1.27~101-g0780600+dfsg-3ubuntu2.1 [13.4 kB]
Get:72 bionic-security/main arm64 libsasl2-2 arm64 2.1.27~101-g0780600+dfsg-3ubuntu2.1 [43.1 kB]
Get:73 bionic-updates/main arm64 libldap-common all 2.4.45+dfsg-1ubuntu1.6 [17.0 kB]
Get:74 bionic-updates/main arm64 libldap-2.4-2 arm64 2.4.45+dfsg-1ubuntu1.6 [132 kB]
Get:75 bionic-security/main arm64 python2.7 arm64 2.7.17-1~18.04ubuntu1.1 [248 kB]
Get:76 bionic-security/main arm64 libpython2.7 arm64 2.7.17-1~18.04ubuntu1.1 [904 kB]
Get:77 bionic-security/main arm64 libpython2.7-stdlib arm64 2.7.17-1~18.04ubuntu1.1 [1,854 kB]
Get:78 bionic-security/main arm64 python2.7-minimal arm64 2.7.17-1~18.04ubuntu1.1 [1,140 kB]
Get:79 bionic-security/main arm64 libpython2.7-minimal arm64 2.7.17-1~18.04ubuntu1.1 [335 kB]
Get:80 bionic-security/main arm64 samba-libs arm64 2:4.7.6+dfsg~ubuntu-0ubuntu2.17 [4,388 kB]
Get:81 bionic/main arm64 linux-u-boot-vim3-vendor arm64 0.9-2015.01 [730 kB]
Get:82 bionic-security/main arm64 libwbclient0 arm64 2:4.7.6+dfsg~ubuntu-0ubuntu2.17 [31.0 kB]
Get:83 bionic-security/main arm64 libcom-err2 arm64 1.44.1-1ubuntu1.3 [8,292 B]
Get:84 bionic-security/main arm64 libgcrypt20 arm64 1.8.1-4ubuntu1.2 [325 kB]
Get:85 bionic-security/main arm64 libss2 arm64 1.44.1-1ubuntu1.3 [9,984 B]
Get:86 bionic-security/main arm64 openssl arm64 1.1.1-1ubuntu2.1~18.04.6 [583 kB]
Get:87 bionic-security/main arm64 ca-certificates all 20190110~18.04.1 [146 kB]
Get:88 bionic-updates/main arm64 distro-info-data all 0.37ubuntu0.7 [4,676 B]
Get:89 bionic-updates/main arm64 libdevmapper1.02.1 arm64 2:1.02.145-4.1ubuntu3.18.04.3 [100 kB]
Get:90 bionic-updates/main arm64 dmsetup arm64 2:1.02.145-4.1ubuntu3.18.04.3 [65.1 kB]
Get:91 bionic-security/main arm64 file arm64 1:5.32-2ubuntu0.4 [21.7 kB]
Get:92 bionic-security/main arm64 libmagic1 arm64 1:5.32-2ubuntu0.4 [61.9 kB]
Get:93 bionic-security/main arm64 libmagic-mgc arm64 1:5.32-2ubuntu0.4 [184 kB]
Get:94 bionic-security/main arm64 iproute2 arm64 4.15.0-2ubuntu1.1 [654 kB]
Get:95 bionic-security/main arm64 libisc-export169 arm64 1:9.11.3+dfsg-1ubuntu1.12 [137 kB]
Get:96 bionic-security/main arm64 libdns-export1100 arm64 1:9.11.3+dfsg-1ubuntu1.12 [623 kB]
Get:97 bionic-security/main arm64 libglib2.0-data all 2.56.4-0ubuntu0.18.04.6 [4,540 B]
Get:98 bionic-security/main arm64 libicu60 arm64 60.2-3ubuntu3.1 [7,987 kB]
Get:99 bionic-security/main arm64 libjson-c3 arm64 0.12.1-1.3ubuntu0.3 [19.7 kB]
Get:100 bionic-security/main arm64 libxml2 arm64 2.9.4+dfsg1-6.1ubuntu1.3 [547 kB]
Get:101 bionic-security/main arm64 linux-base all 4.5ubuntu1.2 [17.7 kB]
Get:102 bionic-updates/main arm64 nplan all 0.99-0ubuntu3~18.04.3 [1,800 B]
Get:103 bionic-security/main arm64 sudo arm64 1.8.21p2-3ubuntu1.2 [382 kB]
Get:104 bionic-security/main arm64 tzdata all 2020a-0ubuntu0.18.04 [190 kB]
Get:105 bionic-security/main arm64 xxd arm64 2:8.0.1453-1ubuntu1.3 [48.4 kB]
Get:106 bionic-security/main arm64 vim arm64 2:8.0.1453-1ubuntu1.3 [981 kB]
Get:107 bionic-security/main arm64 vim-tiny arm64 2:8.0.1453-1ubuntu1.3 [404 kB]
Get:108 bionic-security/main arm64 vim-runtime all 2:8.0.1453-1ubuntu1.3 [5,436 kB]
Get:109 bionic-security/main arm64 vim-common all 2:8.0.1453-1ubuntu1.3 [70.6 kB]
Get:110 bionic-updates/main arm64 ubuntu-minimal arm64 1.417.4 [2,704 B]
Get:111 bionic-security/main arm64 libirs160 arm64 1:9.11.3+dfsg-1ubuntu1.12 [16.9 kB]
Get:112 bionic-security/main arm64 dnsutils arm64 1:9.11.3+dfsg-1ubuntu1.12 [132 kB]
Get:113 bionic-security/main arm64 bind9-host arm64 1:9.11.3+dfsg-1ubuntu1.12 [48.2 kB]
Get:114 bionic-security/main arm64 libbind9-160 arm64 1:9.11.3+dfsg-1ubuntu1.12 [24.7 kB]
Get:115 bionic-security/main arm64 libisccfg160 arm64 1:9.11.3+dfsg-1ubuntu1.12 [42.3 kB]
Get:116 bionic-security/main arm64 libisccc160 arm64 1:9.11.3+dfsg-1ubuntu1.12 [15.7 kB]
Get:117 bionic-security/main arm64 libdns1100 arm64 1:9.11.3+dfsg-1ubuntu1.12 [800 kB]
Get:118 bionic-security/main arm64 libisc169 arm64 1:9.11.3+dfsg-1ubuntu1.12 [195 kB]
Get:119 bionic-security/main arm64 liblwres160 arm64 1:9.11.3+dfsg-1ubuntu1.12 [30.4 kB]
Get:120 bionic-updates/main arm64 libdrm-common all 2.4.101-2~18.04.1 [5,560 B]
Get:121 bionic-updates/main arm64 libdrm2 arm64 2.4.101-2~18.04.1 [28.4 kB]
Get:122 bionic-updates/main arm64 libxau6 arm64 1:1.0.8-1ubuntu1 [7,088 B]
Get:123 bionic-security/main arm64 multiarch-support arm64 2.27-3ubuntu1.2 [6,920 B]
Get:124 bionic-updates/main arm64 python-apt-common all 1.6.5ubuntu0.3 [16.8 kB]
Get:125 bionic-updates/main arm64 python3-apt arm64 1.6.5ubuntu0.3 [149 kB]
Get:126 bionic-security/main arm64 rsync arm64 3.1.2-2.1ubuntu1.1 [308 kB]
Get:127 bionic-security/universe arm64 apt-transport-https all 1.6.12ubuntu0.1 [1,692 B]
Get:128 bionic-security/main arm64 libbinutils arm64 2.30-21ubuntu1~18.04.3 [417 kB]
Get:129 bionic-security/main arm64 binutils-common arm64 2.30-21ubuntu1~18.04.3 [196 kB]
Get:130 bionic-security/main arm64 binutils arm64 2.30-21ubuntu1~18.04.3 [3,368 B]
Get:131 bionic-security/main arm64 binutils-aarch64-linux-gnu arm64 2.30-21ubuntu1~18.04.3 [2,168 kB]
Get:132 bionic-security/universe arm64 bluetooth all 5.48-0ubuntu3.4 [3,152 B]
Get:133 bionic-security/main arm64 libasan4 arm64 7.5.0-3ubuntu1~18.04 [335 kB]
Get:134 bionic-security/main arm64 libubsan0 arm64 7.5.0-3ubuntu1~18.04 [117 kB]
Get:135 bionic-security/main arm64 g++-7 arm64 7.5.0-3ubuntu1~18.04 [8,077 kB]
Get:136 bionic-security/main arm64 gcc-7 arm64 7.5.0-3ubuntu1~18.04 [7,772 kB]
Get:137 bionic-security/main arm64 libstdc++-7-dev arm64 7.5.0-3ubuntu1~18.04 [1,471 kB]
Get:138 bionic-security/main arm64 libgcc-7-dev arm64 7.5.0-3ubuntu1~18.04 [833 kB]
Get:139 bionic-security/main arm64 libgfortran4 arm64 7.5.0-3ubuntu1~18.04 [248 kB]
Get:140 bionic-security/main arm64 cpp-7 arm64 7.5.0-3ubuntu1~18.04 [7,046 kB]
Get:141 bionic-security/main arm64 gcc-7-base arm64 7.5.0-3ubuntu1~18.04 [18.3 kB]
Get:142 bionic-security/main arm64 curl arm64 7.58.0-2ubuntu3.9 [152 kB]
Get:143 bionic-security/main arm64 libcurl4 arm64 7.58.0-2ubuntu3.9 [180 kB]
Get:144 bionic-security/main arm64 git-man all 1:2.17.1-1ubuntu0.7 [804 kB]
Get:145 bionic-security/main arm64 libcurl3-gnutls arm64 7.58.0-2ubuntu3.9 [179 kB]
Get:146 bionic-security/main arm64 git arm64 1:2.17.1-1ubuntu0.7 [2,952 kB]
Get:147 bionic-security/main arm64 glib-networking-common all 2.56.0-1ubuntu0.1 [3,476 B]
Get:148 bionic-security/main arm64 glib-networking-services arm64 2.56.0-1ubuntu0.1 [8,136 B]
Get:149 bionic-security/main arm64 glib-networking arm64 2.56.0-1ubuntu0.1 [48.4 kB]
Get:150 bionic-updates/main arm64 libasound2 arm64 1.1.3-5ubuntu0.5 [294 kB]
Get:151 bionic-updates/main arm64 libasound2-data all 1.1.3-5ubuntu0.5 [38.7 kB]
Get:152 bionic-security/universe arm64 libavutil55 arm64 7:3.4.8-0ubuntu0.2 [174 kB]
Get:153 bionic-security/main arm64 librsvg2-common arm64 2.40.20-2ubuntu0.2 [4,804 B]
Get:154 bionic-security/main arm64 librsvg2-2 arm64 2.40.20-2ubuntu0.2 [81.0 kB]
Get:155 bionic-security/universe arm64 libswresample2 arm64 7:3.4.8-0ubuntu0.2 [45.3 kB]
Get:156 bionic-security/universe arm64 libavcodec57 arm64 7:3.4.8-0ubuntu0.2 [4,074 kB]
Get:157 bionic-security/main arm64 libssh-gcrypt-4 arm64 0.8.0~20170825.94fa1e38-1ubuntu0.6 [147 kB]
Get:158 bionic-security/universe arm64 libavformat57 arm64 7:3.4.8-0ubuntu0.2 [841 kB]
Get:159 bionic-security/universe arm64 libavresample3 arm64 7:3.4.8-0ubuntu0.2 [39.1 kB]
Get:160 bionic-security/universe arm64 libpostproc54 arm64 7:3.4.8-0ubuntu0.2 [33.4 kB]
Get:161 bionic-security/universe arm64 libswscale4 arm64 7:3.4.8-0ubuntu0.2 [116 kB]
Get:162 bionic-security/universe arm64 libavfilter6 arm64 7:3.4.8-0ubuntu0.2 [734 kB]
Get:163 bionic-security/main arm64 libbluetooth3 arm64 5.48-0ubuntu3.4 [57.9 kB]
Get:164 bionic-security/main arm64 libcomerr2 arm64 1.44.1-1ubuntu1.3 [2,708 B]
Get:165 bionic-updates/main arm64 libdrm-amdgpu1 arm64 2.4.101-2~18.04.1 [15.8 kB]
Get:166 bionic-updates/main arm64 libdrm-etnaviv1 arm64 2.4.101-2~18.04.1 [10.4 kB]
Get:167 bionic-updates/main arm64 libdrm-nouveau2 arm64 2.4.101-2~18.04.1 [14.5 kB]
Get:168 bionic-updates/main arm64 libdrm-radeon1 arm64 2.4.101-2~18.04.1 [19.2 kB]
Get:169 bionic-security/main arm64 libwayland-server0 arm64 1.16.0-1ubuntu1.1~18.04.3 [25.6 kB]
Get:170 bionic-updates/main arm64 libegl-mesa0 arm64 20.0.8-0ubuntu1~18.04.1 [80.7 kB]
Get:171 bionic-updates/main arm64 libgbm1 arm64 20.0.8-0ubuntu1~18.04.1 [24.8 kB]
Get:172 bionic-updates/main arm64 libglx-mesa0 arm64 20.0.8-0ubuntu1~18.04.1 [119 kB]
Get:173 bionic-updates/main arm64 libglapi-mesa arm64 20.0.8-0ubuntu1~18.04.1 [30.4 kB]
Get:174 bionic-security/main arm64 libwayland-client0 arm64 1.16.0-1ubuntu1.1~18.04.3 [20.6 kB]
Get:175 bionic-updates/main arm64 libgl1-mesa-glx arm64 20.0.8-0ubuntu1~18.04.1 [5,532 B]
Get:176 bionic-updates/main arm64 libjson-glib-1.0-common all 1.4.2-3ubuntu0.18.04.1 [3,480 B]
Get:177 bionic-updates/main arm64 libjson-glib-1.0-0 arm64 1.4.2-3ubuntu0.18.04.1 [48.2 kB]
Get:178 bionic-security/main arm64 libllvm8 arm64 1:8-3~ubuntu18.04.2 [11.3 MB]
Get:179 bionic-security/main arm64 libmysqlclient20 arm64 5.7.31-0ubuntu0.18.04.1 [659 kB]
Get:180 bionic-updates/main arm64 libnm0 arm64 1.10.6-2ubuntu1.4 [243 kB]
Get:181 bionic-security/main arm64 libopenexr22 arm64 2.2.0-11.1ubuntu1.3 [524 kB]
Get:182 bionic-security/main arm64 libpq5 arm64 10.12-0ubuntu0.18.04.1 [92.7 kB]
Get:183 bionic-updates/main arm64 libpulse0 arm64 1:11.1-1ubuntu7.9 [208 kB]
Get:184 bionic-security/main arm64 libwayland-cursor0 arm64 1.16.0-1ubuntu1.1~18.04.3 [9,332 B]
Get:185 bionic-security/main arm64 libwayland-egl1 arm64 1.16.0-1ubuntu1.1~18.04.3 [5,364 B]
Get:186 bionic-updates/main arm64 rfkill arm64 2.31.1-0.4ubuntu3.6 [22.3 kB]
Get:187 bionic-security/main arm64 sysstat arm64 11.6.1-1ubuntu0.1 [257 kB]
Get:188 bionic-updates/main arm64 network-manager arm64 1.10.6-2ubuntu1.4 [1,237 kB]
Get:189 bionic-updates/main arm64 software-properties-common all [10.0 kB]
Get:190 bionic-updates/main arm64 python3-software-properties all [23.8 kB]
Get:191 bionic-security/main arm64 python-pil arm64 5.1.0-1ubuntu0.3 [277 kB]
Get:192 bionic-updates/main arm64 u-boot-tools arm64 2019.07+dfsg-1ubuntu4~18.04.1 [142 kB]
Get:193 bionic-updates/main arm64 unattended-upgrades all 1.1ubuntu1.18.04.14 [41.7 kB]
Fetched 158 MB in 28s (5,718 kB/s)                                             
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 71214 files and directories currently installed.)
Preparing to unpack .../libgomp1_8.4.0-1ubuntu1~18.04_arm64.deb ...
Unpacking libgomp1:arm64 (8.4.0-1ubuntu1~18.04) over (8.3.0-6ubuntu1~18.04.1) ...
Preparing to unpack .../gcc-8-base_8.4.0-1ubuntu1~18.04_arm64.deb ...
De-configuring gcc-8-base:armhf (8.3.0-6ubuntu1~18.04.1) ...
Unpacking gcc-8-base:arm64 (8.4.0-1ubuntu1~18.04) over (8.3.0-6ubuntu1~18.04.1) ...
Preparing to unpack .../gcc-8-base_8.4.0-1ubuntu1~18.04_armhf.deb ...
Unpacking gcc-8-base:armhf (8.4.0-1ubuntu1~18.04) over (8.3.0-6ubuntu1~18.04.1) ...
Preparing to unpack .../libgcc1_1%3a8.4.0-1ubuntu1~18.04_armhf.deb ...
De-configuring libgcc1:arm64 (1:8.3.0-6ubuntu1~18.04.1) ...
Unpacking libgcc1:armhf (1:8.4.0-1ubuntu1~18.04) over (1:8.3.0-6ubuntu1~18.04.1) ...
Preparing to unpack .../libgcc1_1%3a8.4.0-1ubuntu1~18.04_arm64.deb ...
Unpacking libgcc1:arm64 (1:8.4.0-1ubuntu1~18.04) over (1:8.3.0-6ubuntu1~18.04.1) ...
Setting up gcc-8-base:arm64 (8.4.0-1ubuntu1~18.04) ...
Setting up gcc-8-base:armhf (8.4.0-1ubuntu1~18.04) ...
Setting up libgcc1:arm64 (1:8.4.0-1ubuntu1~18.04) ...
Setting up libgcc1:armhf (1:8.4.0-1ubuntu1~18.04) ...
(Reading database ... 71214 files and directories currently installed.)
Preparing to unpack .../libitm1_8.4.0-1ubuntu1~18.04_arm64.deb ...
Unpacking libitm1:arm64 (8.4.0-1ubuntu1~18.04) over (8.3.0-6ubuntu1~18.04.1) ...
Preparing to unpack .../libstdc++6_8.4.0-1ubuntu1~18.04_arm64.deb ...
Unpacking libstdc++6:arm64 (8.4.0-1ubuntu1~18.04) over (8.3.0-6ubuntu1~18.04.1) ...
Setting up libstdc++6:arm64 (8.4.0-1ubuntu1~18.04) ...
(Reading database ... 71214 files and directories currently installed.)
Preparing to unpack .../00-liblsan0_8.4.0-1ubuntu1~18.04_arm64.deb ...
Unpacking liblsan0:arm64 (8.4.0-1ubuntu1~18.04) o


Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ca-certificates (20190110~18.04.1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
khadas@Khadas:~$ date
Fri Jul 31 02:02:19 UTC 2020
khadas@Khadas:~$ cat /etc/fenix-release 

sorry for the late reply.
See my post above – it is specifically the opencv package (and it’s dependencies) that are broken.