VIM2 with graphical artifacts

Hi there,

I used a VIM2 24/7 for about a year, with the firmware shipped on it. Since the first days, I installed the Khadas cooler, without fan.

About 1 week ago, due to the bug related with ethernet connection (I used Wi-Fi before), I just updated it to the newest firmware (v190518), and everything runs OK. The 4K@60fps resolution also worked ok (had some problems on the original firmware).

Now, about 1 week after the update, there are a lot of graphical artifacts, as you can see on this video:

I’m not sure if artifacts are related in some way with the newest firmware, but it worked ok for a week. I tried with alternative power adapter, power cable, HDMI cable and other resolutions, but the problem remains.

Does anyone have a hint about the problem?


1.reset to factory tried?

2.very similar to a hardware problem, only a question, is the problem in the matrix itself or wim2 ?!

Thank you for your reply.

  1. Not yet. Besides few configurations I don’t want to lose, none config changed since it is working well, so I think it’s very unlikely to solve the problem. Anyways, I will try a factory reset asap.

  2. I’m not sure what you want to say with “matrix”. I don’t know how to answer that question.

Hello, If you gently wiggle the HDMI cable at either end, can you induce the artifacts?

1 Like have only such a problem with vim2?
2.can see how it works with other devices?
3. yes, maybe the HDMI port itself does not work well, change to a different HDMI port on the TV!

1 Like

No, it has no effect on the image.

Yes, the main thing, try vim2 on another TV, and tell me how it will be

1 Like
  1. Yes. I use the TV with a set top box and also a computer
  2. It works well
  3. Already tried other HDMI ports and the problem is only related with VIM2

Also tried in another TV and even a PC monitor. Same problem everywhere with VIM2.

reinstall the firmware, see how it will be.
You can backup just in case!

That’s what I’ll try next.
Just tried a factory reset, and the artifacts shows even on boot animation, but not in Khadas logo):

try erase eMMC completely and install from scratch

although more and more like a hardware problem

1 Like

Ok. Just installed V180619, problem remains, and then installed again V190518… and the problem still remains.
Both times used the option “Erase all”.

It seems that I have now a piece of garbage :frowning_face:

Disassemble completely vim and inspect the board carefully, touch the ports, in particular HDMI, it may swing. I noticed that after some manipulations you started to have a problem, remember what could be the reason

try to load in Krescue , there is no load on the image , there may be something with the GPU

Just tried Krescue and a some operating systems: LAKKA, CoreElec, OpenWRT, Ubuntu.

The conclusion is that the problem is just related with 3D accelerated graphics. If there are no accelerated graphics, everything runs well.

Does anyone know someone from Khadas staff who can give me a hint? I tried the email, but didn’t receive any reply.

1 Like

Hi, did you try the latest VIM2 Android 9.0 Pie preview image, please see if the problem still persists, in that case, it might be some Hardware problem…

Yes, tried it. The problem remains.

Yes, this is a very strange behavior, I don’t know what it is connected with, but apparently there’s something with the graphics

@Fearbrain, by chance is the HDMI cable close to some metal part, Other electronics, Live electrical wires etc. it could be due to interference…