VIM2 Wifi stopped working

Hello. I have a VIM2. Wifi was working OK, but recently it started to work only sometimes, and now it does not work at all. In Linux, there is no wlan0 interface, and in Android wifi remains turned off and you cannot turn it on.

I collected a log from the UART console, it is here:

Any help is much appreciated. Thanks.

Are you sure your router is stable?

I don’t think the router has anything to do here. As I said, the wifi interface is not even present, as if it did not exist. Please look at the console logs in the link I attached, there is some error in bringing the interface up.
Anyway, thank you for trying to help.

Well, what kind of firmware do you have?

I tested with different versions of Android, and also with Armbian. All the same result: wifi interface does not appear.

It seems like a hardware fault to me, but I would like someone from Khadas staff to confirm, if possible.

@huantxo I went though the logs and this part was quite concerning…

as seen with the green highlight, the wifi keeps getting enabled and disabled thoughout the entire log
almost 1000 times, literally.

and at the last one it disables its power as well, totally shutting it off,
Its quite hard to correlate it as a hardware problem, more as a hardware thing messing with a software setting…

please write your concern to Numbqq, Frank, or any of the Khadas staff
by pinging them with a “@” infront of their name

stay safe & good day

1 Like

So you think it can be solved by software? @numbqq @Frank what do you think, is there any solution for my board?

Pay attention to how well the antennas are fixed on the board.

1 Like

Not appearing on the network config has no connection with the antenna placement, I don’t understand how you can even quote this.

I’m not surprised that you understand little of this, I have already been convinced of this more than once.

If this was happening on my VIM2, I would clear the eMMC and then run an Ubuntu from SD card. If I could not get a response from WiFi, I would lean towards hardware issue.
But I agree with others that you should @ one of the Khadas Team.

My VIM3 has no antenna connected, WiFi option in OS still active. I do not use it, but it still works inside OS. So I do not believe antenna connection would stop OS from seeing WiFi module.

1 Like

I want to remind you that antennas are part of the equipment, including the connectors where these antennas are inserted, but I’m not saying that this is the problem!

It’s about vim2

Yes, they are part of it, I just do not believe it would cause WiFi module to be unavailable to the OS. Bad antenna connection will cause poor performance, but I that is not the user’s issue.

Yes, we are talking VIM2, this I know, but similarities of this nature will be common between devices. I mentioned VIM3 as an example of no antenna connected to illustrate it would not deny OS access to the module…in any VIM model.

Of course, WiFi should not be used without antenna.

@RDFTKV Thanks, I will try your suggestions

@Vladimir.v.v It’s OK, I already unmounted and unplugged the antennas, and plugged them back, but it didn’t help. Of course, a bad antenna connection could cause some short in the device, or something alike, but looks like this is not the case

To clarify my suggestion, I mean to boot and run Ubuntu from SD card, just for testing. Did not mean to install Ubuntu firmware using SD card firmware method.

Though it turned out to not be a factor in your case, that is a good consideration, I had overlooked. It was a good suggestion to check @Vladimir.v.v.

1 Like

Wiped out the emmc, tried Ubuntu from the SD card, and still Wifi not showing up. Bluetooth works perfectly, though.

Looks like a hardware issue, awaiting for some response from the Khadas team to confirm this. @RDFTKV I already pinged @Frank and @numbqq, any other suggestion?

I would wait and see what Khadas says. You may want to make available to them the board revision you have, as more than one revision exists.

No, I meant suggestions about whom should I ping that could be able to figure out the issue.

Board revisin is KVIM2 1.2

Maybe @goenjoy. @Electr1 may have a better suggestion for who to @.

Hello @huantxo

So you tried all the Android/Ubuntu images and none of them Wi-Fi working?

Can you take a high definition photo of the Wi-Fi model?