Vim2 Max wont turn on (partially solved)

Hi folks.

I have a Khadas Vim2 Max 64GB with official heatsink, fan cooler and red case. It is beautiful!

I only use it to watch Netflix, YouTube and some IPTV. No other peripherals.

4 days ago I was watching IPTV and it suddenly stopped working. It wont turn on even if the white LED stays on. There was no way, I tried M-Register, Power ON and Reset procedure, but no video output trough HDMI. Just a solid white LED.

So as I am an electronics technician and Electrig Engineer, I started to probe the power supplies of my Vim2 V1.2 pcb using the provided schematic from here:


It took me about 5 minutes to discover that the voltage “VDD_EE” was not present. All the other power supplies were ok. Then I checked the datasheet of the “MP8756GD” and did probe it to see if it was enabled, and sure it was enabled (trough pin 12) and there was 5V on VIN pin.

To be sure that the problem was only at this MP8756 chip, I forced the 0.8V output with an external power supply. And guess what? It turned on normally! I did solder two wires over C9 (this is the output of capacitor from the 0.8V core voltage)

I have the Vim2 since 2018.08.22. Bought it from Aliexpress store “DIYzone Store”, and they told me to post this issue here in this forum.

I would like to fix it. The question is: Where can I find this component in order to fix my Khadas vim2 64gb V1.2? I have the tools for soldering the component using hot air.

Some images below:

If it turn our our quality issues, can return back for free.

If you want to try it by yourself, we are happy to ship you one or two chips instead.

Have fun!

Thank you. But I live in Brazil, I think it is a little expensive to send items to another countries. It may be better if you send me these two IC’s then I can fix it.

Have you ever seen this problem before?

Honest to say, no yet :smile:

Thanks, it works for us, please PM me the shipping information.

Good day!

Dear Gouwa, the fact that I did reflow the IC and did an external supply in order to find out the problem, didnt void the warranty? I cant find the option to send you a Private Message.

Hello, If you click his avatar, a screen will pop up and you will see the message key.

1 Like

Dear Gouwa. Today I managed to fix my khadas Vim2. I found the components for sale on a local distributor, and ordered one piece of it. It arrived today, and did start to replace it.

Finished replacing it, I tried to turn on the board, but nothing. Same issue. So I removed the new U3 (MP8756GD) chip, and started to probe and measure the nearby components. The C17 was very strange measuring no capacitance and 6.3 ohms over it. I checked the datasheet and this capacitor is used to stabilize its internal vcc supply. So I removed it, soldered the U3 again, and plugged the khadas board on TV, powered it on and Bingo! It showed Khadas logo!

As I didn’t have this size capacitor, I managed to solder a normal 1uf 0805 cap in order to let it good for use again.

So, the problem never was the U3 component, but the C17 capacitor that was shorted (and so the internal voltage was pulled to 0V and the U3 chip was no able to work)… I cand understand why this happened while I was watching IPTV.

So I just would like to share my experience and give you a feedback.

Below you can see some pictures of my work.


Thanks for update!

Actually, we already shipped out the chips 10 days ago, please check your PM for the tracking number :smile:

Good day!