VIM2 completely dead


#1

Hi,

The VIM 2 I purchased last month is unexpectedly dead. It was working just last week when I tried getting 4K output to work. Now that balbes gave me the answer in needing Kodi 18, I flashed a USB drive and went to power on my VIM2, when I noticed the blue light didn’t come on. I’ve tried multiple cables & power supplies (both 5v/2a), and nothing. I needed the VIM2 for next Saturday, so this is very disappointing.

What are my options? Is there a warranty with this product? If not, I am very disheartened to think I spent $140 for this only to last a month.


#2

Hello, Are using the supplied USB to USB-C cable for power? If so, as a test, try powering the device by one of the regular USB ports.


#3

Yes I am using the supplied USB to USB-C cable for power, as well as an additional USB to USB-C cable for testing. The VIM2 is now powering up and booting to Android, however, the blue light is still off when the unit is powered down. I’m guessing something is going wonky. Any ideas what could be going on?


#4

Everything is working now. You can delete this thread. If the issue returns, I’ll take it up with the reseller.


#5

I have found the Power led on the VIM2 has some weird effects and can get a mind of its own,
Could be in Software that is running or was,

The control to LED is a weird state