VIM1 Android Nougat V180619 ROM Release

Here release the Android Nougat ROM

Check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: VIM1_Nougat_V180619.7z

  • MD5SUM: ac0a7df644ac12f85e6a7d415a7f8976

  • The ROM is for EMMC installation only

Change Log

  • add 5G hotspot support for VIM1 Pro
  • add Tone board support
  • fixup ethernet issue
  • fixup some hdmi issues

Upgrade guidance:


Following the name It doesn’t have root? And issue with time reset is fixed? Sorry for the simple questions :slight_smile:

The all android release rom have root now.

What do you mean?

I say about RTC. When i disconnect power time resets in spite of RTC battery connected.

Yes, the RTC issue was fixed.
You can refer to this commit

Sorry for the such questions. I have this problems, and me put out of temper. Thanks

Hey. Is there a complete remote control in Google applications?


Thank you for this new release.

It seems that Netflix are not working on this release, like any Nougat release except 170421.
I can launch the app, but I get a black screen after the “Netflix loading screen”.

Do you have any idea what’s going on ?

Tried with latest official APK provided by Netflix (
Also tried to activate all perm’s before launching it.

By advance, thank you.

1 Like

I also have the same problem.
You try disable hw overlays, and open Netflix.


Hi @hungphutho, thank you for this advice, it actually worked !
I enable this option and now Netflix is working like a charm !


@Terry you can fix this problem? Possible cause of this commitment? control for amlogic medias

Because build 170421 no problem .
Thanks .

Thanks for your help. But I think it has nothing to do with this commit :grinning:. Maybe the Netflix is relevant to hardware/amlogic/hwcomposer .

1 Like


Some follow up.
It seems that I have to re-enable the “Disallow HW overlay” everytime I reboot my Khadas (since it turn off even with the appropriate option in the settings).

@Terry have you figured/identified the problem with the last firmwares and netflix? (Is more than a year that we are waiting for this.)
Also I have a question about the remote when set in mouse mode. Is there a way to keep pressing the left click button to have a drag 'n drop feature? (e.g. press the center button and the direction button simultaneously)

@Terry Can you please check the commits

(On PD #142462 the line 970 shouldn’t also get deleted/removed?)