VIM Android Oreo V171229 Preview Rom Release

Here release the Android Oreo preview ROM, check Firmware Page to download the ROM.

ROM Infos:

  • ROM version: VIM_Oreo_Preview_V171229.7z

  • MD5SUM: 192513e0aedd98fd4090d56645ed2251

  • The ROM is for EMMC installation only

Upgrade guidance:

Enjoy & happy new year!


Looking good first Preview…

Many apps Play Store not compatible to be expected
Using Aptoide all good

UI appears snappy

System .gif 5 frames enlarge to see animation

Tap and Hold to add Widgets with Remote or Keyboard/Mouse does not happen as yet.


Getting fail at 2 percent burning tool. What route did you use to flash? I am on sc rom now.

And that is on your VIM1?

Yes going to download it again see what’s up

Think windows issues it’s updating now… . Few hours later I’ll try again.

Some have found error at 2%…

Use burning tool 2.1.2 seems to work


Yes, same error as Scooter2014 here.

Robert, 2.1.2 worked for me. Thanks.

Sorry, we forgot to update the V2.12 tools.

Nice runs ok. I know preview.

You tube apk not updated normal as new is.
Partitions wrong only show 4 gig men.
Network not working locks out Wi-Fi if plugged in Wi-Fi works once in plugged.

For beta pretty good. Video fast snappy ui. More issues likely to be found but good start for first device with O. :grin:

Hi, terry!
Very good news, let’s wait for the source code!

The source code are available for downloading many days ago:

1 Like

I mean after final release :slight_smile:

Final release? You meant the stable version, right?

Yes, right. :slight_smile:

Will the Oreo release support LDAC and AAC audio codecs ?

I tested the ROM and found the following show stoppers for me

1, Using the ExoPlayer reference player this version of Android not not seem to support MPEG-2 video or AC3 decoding in hardware.

  1. Could not find how to use the balbes150 zip file to get back to LE.


Does the Bluetooth/BLE/BT and Wifi Working at this version?
Also, we’d hope to install the Gapps, is the Google play service work?

Yes, the Bluetooth/Wifi and Gapps all work at this version.

Was from updated to include fixes as well? If not should update to latest release.