Video Khadas vim stopped showing video over HDMI

I was using Khadas VIM3 in my vehicle for several months, when suddenly it stopped showing video,

  • I connected it on TV but it didn’t work either.
    -I tried to reinstall the Firmware, it loaded, but it also didn’t show video.
    Does anyone have a tip?

Have you tried with a new HDMI cable? Sometimes over extended period of times, the hdmi cables get a lot of rust on their connectors and stop working.

1 Like

Yes, I tested another cable

The HDMI connector itself remains, this is a much worse problem.:roll_eyes:

@Celturbo if you have any experience with such devices, try hooking it to your Computer over USB-C and open an ADB shell on your computer, and see if you can interact with it, even try scrcpy (connect your VIM3 to USB3.0 port, USB2.0 will not provide enough power)

if this is too complicated, please seek RMA support from Khadas instead

1 Like

I noticed that many users have problems with HDMI, while communication with the board is not broken, the problem is not clear yet.:man_shrugging:t3:

1 Like

that old issue was related to a problem in the g12b SoCs and was linked to a problem in the FETs driving the HDMI display registers, but lets not jump to conclusions before making sure its not this is not based on other faults…

1 Like

I sent some ADB commands, it responds normally.

@Celturbo Has hdmi not been displayed since your board was turned on ? I’m not sure exactly what your problem is

It worked normally, suddenly stopped sending video over HDMI

Apparently, the problem is of a hardware nature, you need to look according to the board scheme, proceed from the HDMI port, and then according to the scheme …

did you check if the HDMI port itself is in good condition ? doesn’t wiggle or have any hardware defects.

I bought another Khadas VIM3L, but the same problem ended up happening. :pensive:

I suspect the problem is with your TV, please try connecting other devices.

I tested it on other screens, it gave the same problem

yes they are good apparently,
now i have two Khadas with the same problem

I got to see the schematic, but the components are small