USB issue on VIM3

Hello everyone

I have been tinkering with VIM3pro for a while now. Everything was working as I wished. Using 12V USB-PD powersource. Now I recieved Quectel EM06-E LA card, which I installed on M2X board. Next boot and all USB ports were dead. I managed to update Android through USB-C port using PC on the other end. Now everything is still working, but I have no control on system. USB mouse, keyboard or touchpad is not working. I have also tried USB-C hub with USB-PD pass-through, but no luck. Any ideas? Everything seems to be OK physically on the board.

I’d recommend you to look into KBI documentation by Khadas.

That will give you some idea about the issue.

@MikaL Did you reburn a new image ? I think there may be a problem with the hardware, can use lsusb command to recognize it?

Yes, I burned new image after problem started. I think the motion sensing is new feature in last image. Now VIM3 is recognizing it’s orientation in Android.

Problem using any commands is that I can’t connect keyboard to usb or get VIM3 to pair with BT keyboard :cry:

@MikaL Did you know how to use adb ? It don’t need to use usb . You can follow this pages. And faceback about lsusb command.

I have been trying to get connection to Vim3 using Ubuntu on laptop. Using ethernet and USB-C no response. Testing connection to gives faulty connection and trying to ping that IP end in loop. I also tested both USB A ports and neither gives no voltage between any pins. I burned latest Android image again with WIN10 desktop through USB-C in maskrom mode and it went as should. Also VIM3 seems to function as should, just no USB. Other observation is that fan is not running at boot as it did before these problems. I have been through checking board on both sides with magnifying glass and powerful light. No obvious damage anywhere.

I probably order new Vim3 and keep this problem solving on background of main project.

Did you ever try to power the VIM3 with VIN port? Or Did you ever try to insert the DC adapter into VIM3 USB A port?

After problems started and I had tried re-installing Android and factory reset I did try to power Vim3 through M2X USB-C. But never through USB-A.

I means whether you do it before you had a problem

Not before problems. Always use USB-PD from high quality adapter.

@katherine @kenny Please follow up this. Thanks


Please unplug your Quectel EM 06-E LA and tell me, is there a problem with the USB ports?

Problem stays the same after removing Quectel modem. Also tried without M2X board.

try a different power supply and cable, this is certainly not 100%, but still

Can you provide photos of your board ?,

Is it kept open or is it placed in a box ? , short circuit might have happened if the board is exposed, and is being supplied with a lot of power, anything is possible,

please review all the possibilities…

he confirmed above that the board is not visually damaged

Maybe the current surge or short circuit caused damage ?
but it is questionable as the USB-C still works,

as I said, we need to review everything…

I think there would be a smell, maybe some diode fuse could be damaged

yes, that is what needs to be observed…