Upgrade Mode not working on VIM3L

Which Khadas SBC do you use?

Hey there ! I´m using Khadas VIM3L

Which system do you use? Android, Ubuntu, OOWOW or others?

Android Version 9

Which version of system do you use? Khadas official images, self built images, or others?

Official VIM3L_PieV211220, also tried vim3l-android-9-64bit-v230725 (both downlowded from official Khadas Website)

Please describe your issue below:

I can’t boot into Upgrade Mode. I want to Install LibreElec on my Vim3L (i downloaded the Official image for Khadas VIM3L from LibreElec Website), so i prepared a SD-Card (i tried multiple ones and also a USB-Stick).

So far i tried to get into Upgrade Mode using the TST and Key Mode. But i can only get into the Android Recovery Mode. I should also mention that I cannot use the buttons to move up or down in this menu. I have to use a pc mouse for that.

I have already checked a few forum threads but cannot find a solution that works for me. Is it possible to Boot LibreElec straight into the eMMc? So far i was just able to install the Android OS, when i tried to install Ubuntu, that failed as well. Loading the LibreElec image into the Burning Tool Software (Amlogic) is also not working. Then all I get is a message that the image check failed.

Does anyone have an idea to solve this problem?

Hello @Leonsu, Welcome to the community.

I believe you might not be timing the release of the buttons correctly, if you do not time them correctly (especially holding down power button for longer period) you will wind up in the android recovery.

Yes, you can flash the device onto the eMMC with the help of OOWOW.

First refer to the links to get started with OOWOW.
OOWOW - getting started
VIM3L - Latest OOWOW SD image

You need to convert the libreelec image to a container format compatible with OOWOW, please check out the guide on the image conversion.

Image conversion using XZE

After getting OOWOW setup, you need to copy the converted image onto the dumps partition of the OOWOW SD Card. And from within OOWOW go to the “write to eMMC” menu, and install the libreelec image.


1 Like

Thanks a lot! I managed to install CoreElec and may try LibreElec, but I don’t see the need for it.

1 Like