Unable to use keyboard in krescue

Anyone have any suggestion on what I need to do? I’m having issues with my Unbuntu install, not able to update the software anymore without a bunch of errors. My plan was to just reinstall everything. I was able to successfully write the Krescue image to an SD card and able to boot to Krescue. However, I cannot get any keyboard to be usable. I’ve tried a wireless keyboard, the same keyboard but hooked up using USB cable, a regular USB cable keyboard…still nothing.

Any suggestions??


Nevermind…while the screen was still showing the text before you see the Krescue menu come up…when I hit keys during that load…I am now able to navigate in the Krescue menu. Who knows.

I may have spoken too fast…after a few seconds the keyboard is disabled. So I guess I am still looking for advice.

@iceburn111 @hyphop will help you with this .

Thank you @Frank, much appreciated!

strange situation - i never see any problem with usb keyboards
(but if u can provide me more detail dmesg i can help)

  1. how device powered? may be try another power adapter
  2. khadas IR remote contorl every time must works (sure if u have this one)
  3. try any other keyboard
  4. if device connecter by ethernet to your router u get krescue access via your browser http://krescue - same u can connect by ssh root@krescue -p22
  5. UART - serial console same works every time
1 Like

@hyphop, sorry it was a busy week for me. 1. I am using the official Khadas power brick. 2. I didn’t try this yet. 3. I have tried 3 different keyboards all hooked up USB and one that has a bluetooth dongle. 4. I was able to use this method to manage the VIM2 in Krescue.

I was able to completely format my eMMC. Sorry if this is a dumb question…excuse my ignorance. I first installed Coreelec. I then installed the linux distro. When you install the two separately do they overwrite each other…or how do I switch between the two?