TS050 not working on VIM3 (Android Pie v200103)

Hi, Khadas Team. I bought the TS050 LDC and it was working for a week, but from one day to another it has stopped working without making any change. I’m using it on VIM3 with lastest Android Pie release (v200103). I’ve checked if FPC cable disconnected accidentally but it’s all ok.
Hope you can help me.

As Khadas team is not available due to the Medical Emergency in China.

Can you please provide some images of the FPC and the connections?
Also have you tried using either one display connection? Example either just use TS050 LCD or just connect HDMI to TV Screen without TS050 connected and see if the board works.

If you can see board working fine on HDMI then please remove the HDMI and try only TS050.

Just to confirm if the board is working or not at this stage.



First of all, thanks for your reply @Spikerguy .

I’ve tried what you say and the board is working properly, with HDMI connection there’s no problem. In fact, checking this I’ve noticed that if I connect both displays at the same time, I can use touchscreen as you can see on this video.

Thanks in advance.

Ok maybe Touch is supported in dual display, but AFAIK dual display is not yet supported in the kernel.

Please power off the device and remove all the connections, then just connect TS050 to the Board and try to boot it, This is just to test if the Uboot Flash Screen appears on the screen or not. As uboot is read only so there wont be any changes to it with os updates.

If there is no Khadas logo when you power it on then it must be either the Flex connectors, flex itself or the lcd logic board issue.

Please try and respond back.

1 Like

I’ve removed all the connections and then I’ve connected only TS050 but Khadas logo still not appearing at boot. Maybe it’s a problem of the flex as you say, I will try to change it and report the results.

Thanks for your help.

Hello, I meet almost the same problem with my VIM3L and TS050. The backlight is on, and the touching function works, but no graphics on the display. Do you solve this problem?

No, I have not solve it yet, but I bought a new TS050 and it works fine. I want to check if the problem is about the flex (testing with the new one) or if the problem is the screen pcb instead. For now I couldn’t check it because of coronavirus I can’t go to work and the stuff is there.

Thanks. Since I am in China, I sent my touchscreen to the dealer where I bought it, and they returned me a new one. In addition, I have tried to change a flex but it did not work on my device, so I think the problem may be on some components or circuit.