Touch screen and Ubuntu 5.5 on EMMC

Hello, we are using Waveshare 15" touch FULL HD screen with VIM3. On kernel ubuntu bionic 4.9 touch does not work. When I switch to ubuntu 5.5 from SD card - touch screen works but no EMMC image of this kernel. How to install ubuntu 5.5 on emmc?

this image suitable for SD and eMMC (via dd )

i will prepare Kresq image for this ubuntu last version soon

but u can still write this image to emmc

  1. just start Krescue from sd - connected to your PC by usb otg cable
  2. check exported disk (on your machine )
lsscsi | grep Krescue

[3:0:0:0]    disk    Krescue. MMC                    /dev/sdc 
[3:0:0:1]    disk    Krescue. SD                       /dev/sdd 
[3:0:0:2]    disk    Krescue. RAM                    /dev/sde 
  1. write image
dd of=/dev/sdc < RAW_IMAGE

or just one command line without unpack image

7z e -so VIM3_*USB*.7z '*/*.img' | dd bs=1M of=/dev/sdc
# or
7z e -so VIM3_*USB*.7z '*/*.img' > /dev/sdc
# or
7z e -so VIM3_*USB*.7z '*/*.img' | pv > /dev/sdc

Thank you for your reply. But we use windows machine for development - but “USB Burning tool” does NOT recognize this image as suitable for burning over emmc.

sure becouse its not amlogic burn image !
this image simple raw compressed image u can write it by any other WIN software for example balenaEtcher

Sorry - still unable to solve the problem. How we can write it from windows machine to emmc? Tried krescue - but it allows only to save dump from emmc. Moreover, it stores dump to SD card partition incompatible with windows. Where we can put this 5.5 image on krescue SD card so it can be burned to emmc?

NO! krescue can do more not only write images!

  1. just connect VIM board by usb otg cable to your HOST working machine
  2. boot Krescue from sd
  3. after system bootup u must have internal VIM storages exported via USB to your HOST machine (is same for LINUX WINDOWS OSX )

Ok, we will try - thank you. Can I ask you about another problem - how to enable UART on 5.5? We tried on systems started from cd card.
As you adviced here: Help! Unable to activate second UART

But it still not working. Even debug UART is not swithced off (still working) when line with tyyAML0 removed from boot.ini

for mainline linux kernel just add or remove this param in kernel boot arg


You mean “remove this paameter from boot arg” ? To stop system use ttyAML0 for debug terminal? So we can use it for our needs? Where to remove it - in boot.ini?

yes ! remove from boot.ini or boot.scr

PS: dont forget boot.scr not plain text file

strip uboot script
dd bs=72 skip=1 < boot.scr > boot.src
build uboot script
mkimage -C none -A arm -T script -d boot.src boot.scr

PSS: boot.ini not used in mainline at this moment :wink:

1 Like

Thank you very much. It works. We wrote 5.5 image on emmc using balena etcher and OTG USB cable from windows. I deleted “console=ttyAML0,115200n8” substring and converted back and forth boot.scr and it worked. Now we a re trying to turn on PIN 15,16 UART. I converted meson-g12b-a311d-khadas-vom3.dtb to .dts file, enabled all serials (disable -> okay) inside, converted to dtb again and replaced boot/dtb.img with this file. But second UART is still not working. Any ideas?

looks like right ! but i can check it only tomorrow !


1 Like