Tone VIM3 Android - No Sound

I have just purchased a VIM3, Touchscreen and a Tone (VIM Edition).
I am running the default Android distribution that came with the VIM3.

I have the touchscreen working but when I play sound (Youtube) I have no audio that comes out of the Tone RCA connectors.

Do I need to enable or configure something?
Does the Tone not work with the current Android distribution?

Things I have tried:
I have a USB C attached to both the VIM and the Tone. -> Still no sound
Plugged in HDMI and do get sound but only through HDMI and not through Tone RCA.

@Mechalec when using the Tone board connected to the GPIO header, the USB-C input is not required…

Many thanks for that advice. I was trying everything to make sure it wasn’t something simple.

When I dont supply USBC to the Tone (40Way header from the VIM only), the LED on the tone does not light up.
Yet when I plug the USBC into the Tone, the LED on the tone does light up.

Is this LED indicative of power or is this something that is associated with the USBC?

I’m not sure of that, perhaps @RDFTKV might have an answer for you

I don’t know off the top of my head. I will check Tone1 and schematic tomorrow and report back.

Many thanks @RDFTKV and also @Electr1!

I honestly have no idea why, but this time I have plugged in USB-C only on the VIM and I now have a white LED on the tone board and now I have SOUND! :slight_smile: WIN!

I also did some investigation into the Tone schematic and I can see that the LED is powered off the 5V rail which is supplied by the VIM3 40W header.

I must have had a loose or bad connection that has now fixed itself.

Many thanks for your support.