Tone-Board v2.00 Firmware upgrade on VIM2 Android v7.1 Nougat

Hello All! …

Here I am again with my Boards-sandwich VIM2 Android v7.1 Nougat + vTV-board + Tone-board…

VIM2ProVtvToneBoard

We can read on Khadas Blog, Tone 1: Upgrade to the Official Khadas Firmware (v2.00), that v2.00 firmware is downloadabe for TONE 1…

As everybody can see my Tone-Board is sandwichly-attached on my Android v7.1 Nougat VIM2 :wink:

Is there any other solution to upgrade Tone-Board than the one explained on the Blog, namely the windows one, or am I supposed to unmout the Tone-Board from the boards-sandwich, connect it on a PC and do the upgrade ?

1 Like

I don’t think it’s needed to unmount the Tone1 just upgrade via the USB-C port will work out.

Have fun!

Hello Gouwa,…

Thaught that there will be a problem because of the power inter-connection between VIM2 Tone-Board and vTV-board…

Just disconnected my Boards-sandwich from my AV installation and connected it directly to my PC through an USB3.0 powered switch and a Khadas USB-C cable…

Tried to start VIM2 (power button), VIM2 and vTV boards seem not to be powered when Tone-board is USB-C powered

Just encounter a ‘code 10’ error on my PC but I think it’s due to Tone-board driver…

I’ll try to upgrade Tone-Board Firmware in v2.0 version this afternoon…

Hello All! …

Tried to Upgrade my Tone-Board, sandwichly-attached on my Android v7.1 Nougat VIM2…
We can say that it’s a success, Tone-Board, sandwichly-attached Firmware Upgrade is OK…

BUT I also have to tell you what happened … suspense, suspense :wink:

First I connected my Tone-Board by it’s USB-C port to my home computer via my USB3.0 powered switch…
Tone-Board (v1.02, v1.04) driver installation … OK
TUSBAudio Firmware Upgrade Application … OK
Tone-Board (v1.02, v1.04) detection … OK
Device Openend and Ready for firmware update …

v2.00 Firmware upgrade failed ! :slightly_frowning_face:

Then I connected my Tone-Board by it’s USB-C port directly to my Laptop E5550…
Tone-Board (v1.02, v1.04) driver installation … OK
TUSBAudio Firmware Upgrade Application … OK
Tone-Board (v1.02, v1.04) detection … OK
Device Openend and Ready for firmware update …

v2.00 Firmware upgrade finished successfully… :slightly_smiling_face:

Then I installed Khadas_Tone_Driver_V4.86.0_201118
Tone1 (v2.00) detection … OK
Windows System Tray - Khadas Audio Dashboard … OK
Launched Tone Series DFU Tool … OK
Tone1 (v2.00) detection … OK

Everything seems to be allright for the next Tone1 and soon (hope so) Tone2 (form my VIM3) Upgrades…

Connected back my Board-sandwich VIM2 v7.1 Nougat + Tone1 v2.00 + vTV-Board on my AV system…

Everything sounds OK, I’m an happy user ! …

Thanks All, for All :wink:

5 Likes