Tone Board not working with RPi and Windows 10

Hi all,
I bought a second hand KTB (generic version) and I used it a couple of days with Rpi 2B and Volumio.
After connecting the a second device to Rpi USB ports (an external cd player), KTB stopped working with led light blinking and it is no more recognized by Volumio.
I tried to remove CD device and replug KTB but nothing changed, running dmesg | grep usb command it seems that each time i plug the KTB, RPi starts to notify “over-current” issue on usb ports.

I then tried to check KTB using a windows PC, drivers are there, KTB is recognized but no sound from it and led light only on when USB cable is plugged then it is off for all the time. I tried with different USB C cables, no change in results.
Even on daphile and moode it is not recognized, so I am guessing some issue with KTB circuit.
Is there a way to check it? Is there anyone can support in troubleshooting?
I would not want to trash it after only a couple weeks.
Thank you

@Eric68 Please help!

Hi, I saw a different way to feed ktb using gpio from Khadas blog. If a short is there, will it work?

The light is blinking,this indicates somewhere has short circuit on your Toneboard.You should send it to us to check.

hello, no way to check by my self?

You can touch every chip,check which chip works with too high temperature.

I think it is not a safe solution, if i connect again KTB to rpi then i can short also USB port from it.
If i use USB feed from GPIO (pin 1 5V, 21 GND, pin 3 USB- and pin 4 USB +). will i get same issue or gpio has a different path?
If it is blinking on RPI is because a short should happen, but why i connect it to a PC i got led on only for a few seconds and then nothing?
as i said, in my pc with KTB driver installed, system recognize it but no sound through it.
Thank you!


Here it is, i have currently connected to a pc.
No strange current value over usb (pic 1), no strange temperature in chips.
The only Thing very hot is the element in pic2. No idea what is .
Any comment?

ok, looking at schematics i found that element is F1 fuse. On its ends I see a delta V of about 3.2V. is it normal?

From schematics I see that F1 is in between a diode IC and C22/C23 capacitors which should be at 5V.
Thank you

F1 is a fuse,it has 3.2V voltage between its two pins.It is not normal. It should be approach 0V. You can measure the voltage of C40/CE3/CE6 to make sure if it is OK,Normally,C40 should be 1.0V,CE3 should be -5.5V,CE6 should be 5.5V.

c40 1.2V , c6 4.8V, c3 0.0V

All the Power output is wrong.So it needs to return to us to repair.

Hi @rsr.grasso
Thanks for ordering the Khadas Tone1(KTB) and sorry for the issue you met now :face_with_peeking_eye:

I guess you are a technician or maker as you are also able to run linux commands and which I think it should be not hard for us to figure out the issue.

I think the USB port (and to to XMOS) should be not problem as your Windows PC able to recognize the Tone1 device. But we still need more details to sort out the problem and maybe you can just follow the guidances below first:

  • Your Rpi setup: check again the current of power adapter and ensure the power adapter able to afford enough current of both Rpi and Tone1, and basically the Tone1 will draw up to 350~500 mA.
  • Your PC setup: show us

And try to:

  • Upload two high resolution photos to show us the bottom and top sides of the second hand Tone1 you have
  • Upload some high resolution photos that show us the setup & connections between Rpi, Tone1 and Power Adapter
  • Upload some high-res photo and show us the setup & connecton between PC, Tone1 and the (headphone) amp and speaker or headphone.

A short video also preferred as it able to provide more information for us.

We are here to help you and will try to make your Tone1 to work again :blush:

Have fun!

1 Like

Hi @Gouwa ,

Thank you for the feedback.

Here follows both sides picture

I have just connected rpi and KTB1 after a couple of days and I got this behavior: initially KTB seemed to work but current absorption from rpi usb was 1.2A more or less. After a couple of seconds, KTB stopped working (probably shutdown as led light off) and current dropped to 0.2A but rpi (volumio) was still playing.
I have a video but I am not able to upload it Here.

Touching the board, f1 seems to be only element with high temperature (board hot On both sides).

Thank you

I have checked your Toneboard,and found some little problem,But I am not sure it is a problem.

  • You can see the picture below which I show you,this place has connected together by metal.You can try to remove this metal,and check the power again.

  • Then you can measure these capacitances’ voltage to make sure it is right.
    1.The first capacitance should be 1.0V normally.
    2.The second capacitance should be -5.5V normally.
    3.The third capacitance should be 5.5V normally.

Hi @Eric68 ,
Honestly i don’t understand why this issue happens now and that pod is the root, as it is soldered as default.
Anyway, I tried to separate as much as possibile where you highlighted .
Here a picture, i home it a clear enough

Current absorption over usb is now 1.07-1.12 A.
Voltage is 1.02 On point1, 5.5 On c2 and -5.5V .
For point2 and point3 i set multimeter positive probe on the side where positive sign was reported.

KTB1 worked a Little longer than yesterday, but Then again it stopped (shutdown as power absorption fell to 0.2 A from USB).
It was very hot ok both board sides as usual.

Thank you.

It seems the power is normal now.but the current absorbtion over USB is 1.07A-1.12A,this is a problem.It should be about 350mA normally.
I want to ask you some questions below:
1、Is the white LED still blinking when power up by connecting USB C to DC adapter?
2、Can be recognized by PC when connect to PC by USB A to C cable?
3、Check all the Power shown in the picture below if they are all right.They are all 3.3V normally.

hi @Eric68 , why do you say power is normal?

To me it seems not normal that KTB stops working after a couple of minutes and during short time it sounds the current is higher than what is expected (1.2A > 0.3-0.5 mA).

I am loosing all hopes with this board.

You are right,I said these three power you measured are OK.

1 Like

any further action needed?