Tone 2 - MQA decoding works sometimes only (same setup and settings)


I have been using the Khadas Tone 2 for almost 1 month now and I am totally in love with this device. Thanks for producing such a masterpiece and offering it for an affordable price.
Unfortunately I have a problem with reliably playing .mqa.flac files such that the Tone 2 does the MQA decoding. I use the same system, setup and files. According to the lights under the control knob, sometimes the Tone 2 does the MQA (studio) decoding, sometimes it shows 44.1 khz PCM mode. I have tested this with the same file. Does anybody know what is happening here?

Setup: PC -> USB 2.0 -> Tone 2 (+ separate power supply) -> RCA -> Amplifier -> Speakers
Tested on Windows 10 and Linux Mint 20.1
Windows 10: Foobar2000 (+ASIO plugin), Tone 2 driver, ASIO mode active
Linux: DeaDBeeF and VLC, both use ALSA directly to communicate with the DAC (Tone2 Pro, USB Audio, Direct hardware device without any conversions)
Testfiles: and

I flashed the Tone 2 using the DFU tool and the firmware from 22. January 2021



Hi,I tested with Foobar2000 1.6.2 on Windows 10, it works OK, both two situations with two testfiles(download from your links) are the same,the RGBs show the MQA studio(blue)/352800Hz(the 4th RGB). But at sometime,when you play MQA files,the DAC will recognize the files as PCM 44.1 at the beginning.You should wait a moment, and then it will show the right formats.


Hey Eric68,

thank you for taking the time to test it. I have downloaded and installed Foobar2000 1.6.2 to establish the same conditions. MQA decoding worked reliably again. With and without ASIO. Then I installed the version I used previously, 1.6.4. It also works reliably again. I remember that when I started to use the DAC with foobar2000 MQA decoding also worked, but over time it worked only sometimes to the point that I could not get the DAC to decode the MQA anymore today. Now it works all well, but I keep an eye on it in case it stops working (reliably) again.
So after all it seems like foobar2000 was the problem and DeadBeeF seems to be unable to stream the audio in a way that the DAC does the MQA decoding. Please correct me here if I am wrong, if not I’d appreciate a recommendation of a free music player for linux that ideally supports all the features of the DAC.


I understand your desire for a free music player, but if you’re using the Tone2 Pro mostly at home (and, it seems we’re all stuck at home these days), I submit that the value a Roon subscription brings to your listening experience and music discovery is far greater than the $9.99/month cost (about the same as two lattes where I live).

I’m using Arch Linux as my preferred O/S for both Core (Roon Server on an Intel Core i3 processor) and Outputs (Roon Bridge on Raspberry Pi 4). Controlling the system is managed via the free Roon apps for Andriod (smartphones, in my case) and iOS (iPad in my case). There are desktop apps for Windows and macOS, but sadly, no Linux Control app exists (some folks have had mixed luck running the Windows version in Wine, but I would not bother).

This solution supports all of the features of the Tone2 Pro. You can even to crazy things like upsampling all of your music to DSD512 (although, you may need an i7 processor to swing that). Roon has a convolution engine, which I use quite successfully for digital room correction. The results are truly amazing.

amplitude response in my room, playing the sweep using Roon’s convolution engine

If you want to give Roon a try, they have a 14-day trial. If you use my referral link for the trial, you’ll get 13 months for the price of 12 if you decide to keep it. This short video provides a quick overview, but there’s way more to it than what you’ll see here.


Some video tutorials:


Thanks for making those, sure many users (especially new users) will find them useful.
Can you still play MQA files (decoded on the Tone2) in foobar2000 after installing the SACD plugin in foobar2000? I think this plugin broke my MQA playback previously which was ultimately the reason I created this thread (“MQA does not work reliably”).

I would also appreciate a video tutorial for the setup of a fully featured player you recommend on Linux.