System won't boot after using emmc-install

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas vim4-ubuntu-22.04-gnome-linux-5.4-fenix-1.1-220721

Please describe your issue below:

I make a backup of my VIM4 to an SD card with krescue but it wouldn’t boot back up afterwards.

Because the other backups I made with krescue are quite old, I restored a recent image to an SD card and tried to put the system back on the eMMC using emmc-install, but it still won’t boot from emmc.

To be sure it isn’t a problem with the emmc, I restored one of the old images made with krescue, which boots and re-installed the same image I’ve been running using OOWOW, which boots as well.

I would really like to be able to restore a current system backup on the emmc so that I don’t have to re-install all the software I’ve put on and redo all the configuration changes I’ve made.

I’ve tried emmc-install a number of times using different working SD cards and am going in circles.

Post a console log of your issue below:

Not sure what would be helpful at this point

@technodevotee The emmc-install command has certain issues on VIM4. It is currently unavailable, and it is recommended to use OOWOW to restore your backup.

I thought only images designed for use with emmc can be installed/restored using OOWOW because the disk structure is different to one designed for an SD card.