State of Linux mainline OpenGL on S905X


For what board and which branch of meta-meson did you use ?

Strange indeed since the Vim uses the S905X internal ethernet PHY, so it’s totally different.

Which Linux tree did you use ?

I checked in VIM 2\16. Last image Armbian Ubuntu with Mate (kernel Neil), run from SD card to manage the connection via SSH. Yes, there is a hang while downloading big data (while getting about 900 MB of hangs). When a small download to GIT (within 300-400 MB), no crashes. For purity of experiment I checked the behavior of the same image from SD card (something to eliminate the effect of packages and settings) on Vega S95 S905. Only replaced the dtb file on meson-gxbb-p200.dtb (with the addition of the patch that indicated above, without it, the network doesn’t work at all). Everything works correctly, no lockups. Hence the reason in features of the kernel + dtb at the network part on S905x ?

Maybe this patch will be helpful. He corrects the work with Gigabit network cards in S905 Vega S95.

--- ./arch/arm64/boot/dts/amlogic/meson-gxbb-p200.dts
+++ ./arch/arm64/boot/dts/amlogic/meson-gxbb-p200-lan.dts
@@ -114,9 +114,9 @@
 		#address-cells = <1>;
 		#size-cells = <0>;
-		eth_phy0: ethernet-phy@3 {
-			/* Micrel KSZ9031 (0x00221620) */
-			reg = <3>;
+		eth_phy0: ethernet-phy@0 {
+			reg = <0>;
+			eee-broken-1000t;

It’s very similar to the patch I’m using to avoid these hangs on my C2.

I’m taking this defconfig.

– edit –

I’ve tried linux-next (4.11.0-rc7-next-20170424) as well, same result.
When the network hang occurs, tcpdump (executed locally on serial console) doesn’t show any incoming packets, a second tcpdump on the network router shows the following outgoing traffic (after a while):

  • NTP traffic
  • ARP requests (KVim inquires the the router’s ethernet address)

these configs
export MACHINE=amlogic-s905x
bitbake amlogic-image-sato

Hi. I gathered with the use of meta-meson image. Recorded on the SD card. Added the autorun script. Try to run, the kernel starts fine, but then panics because of the fact that it can not mount the root partition. The question is, where can I see and change the kernel configuration, which is collected in the image ? I looked at all the config files in the build environment and not find configfile to build the kernel.

1 Like

Same problem with mainline kernel (also with rc5) here I opened issue.
Also sometimes is eth0 detected as only 10Mbps. But this isn’t thread about Network but about Mali support. Maybe @Gouwa can separate this from main thread.

where can I find fbdev lib for mali? I would like to try Kodi 17.0.3 with fbdev at least on Khadas VIM device. I would not like to try any ***ELEC release, or such. Would like to compile on ArchLinuxArm (with mainline kernel).