Startup issue on new Edge2

Which system do you use? Android, Ubuntu, OOWOW or others?

None yet

Which version of system do you use? Khadas official images, self built images, or others?

Machine won’t boot yet so haven’t considered this

Please describe your issue below:

I have a new Edge2 which just arrived, however it doesn’t seem to boot. I’ve tried a couple of different monitors over both HDMI and USB-C (using the correct USB-C port) and the fan whirs twice for a second, the left light turns on, the right light blinks a few times, then left light turns green, flashes blue twice a number of times (like a bluetooth connection light) then nothing. At no point does the display trigger. Have tried holding function and tapping reset but that doesn’t work either.

I’ve created a video demonstrating the problem:

Is there any advice you can offer?

Post a console log of your issue below:

Can’t get into machine to get Log.

Hello @andrewmackie

In the video you don’t attach the HDMI screen, could you attach the HDMI screen and shoot a video again?


It’s attached to the screen via the single USB-C cable and powered by the screen power supply.
I’ve also tried it to a larger monitor with it powered separately.
But happy to shoot another video if you like? Maybe let me know specifically what you need to see.
Thanks for your help.

Can you check with a 1080P HDMI screen not the DP screen ?

Okay, so I tried HDMI direct and a different power supply and it worked?! Slightly embarrassing but just starting installing an OS.

Sorry to hassle, it’s possible using a different power unit may have been the solution as it wasn’t working through same HDMI previously.

Anyway thanks again for your help.