Problems with video artifacts using SSD w/Ubuntu 20.04 V0.9-20200530 Initial Release

Thank you for the warning, I do care not to connect other additional device in common with that same USB-C port.

yes, the more it’s not known whether this is somehow connected with your problem

I will add that I am using a cheapo Patriot Scorch 128GB NVMe SSD. Also using the Khadas 24 watt PD PS.
It is curious that you have no issue with 4.9 but do with 5.7. As you have had this issue across multiple OSes, I would try a different NVMe ssd if you have one available. Otherwise, you may want to see if there is an available firmware update for your SSD.
As you may know, not every SSD plays well with all systems, not even on x86 platforms. Also I would try a different PS if one is available.

Indeed the problem aroused with 5.7 because it is the first I know of has effective support for NVMe and the problem appears to be NVMe related somehow.
Honestly I’ve not much experience of M.2 NVMe’s but I believe that not any of them can be good for any system. I will try to get the one you indicated and let you know. :smiley:

No I was not recommending the Patriot Scorch, it is just the one I have, only an example. I bought that SSD for $20(USD) shipped. They are much more than that now, better SSDs are available for not much more. Official SSD compatibility list is here. Might be a good idea to see what other’s tests reveal. Your issue could be related to the firmware, I do not know. This firmware is an initial release, bugs are expected to some degree.

I am like you, the Patriot was my first M.2 NVMe SSD. :slightly_smiling_face:
I also assume any should work with all. However, from what I have read on the web, some compatibility issues exist between certain drives and certain platforms. I assume these incompatibilities become less and less as the standard matures. The Patriot uses a low cost controller(Phison), better controllers than it probably offer greater compatibility across platforms.

Just too late :sweat_smile:, I’ve taken one for slightly more than yours, on the other hand the Samsung 960 EVO is much more that that anyway. I considered that if yours worked it would settle my problem also. At any rate yes, talking directly to the PCIe bus could be problematic and individual devices could matter, I think.
If am lucky enough getting the new SSD well by the end of the week I should be able to report.

Oh No!!! :laughing:
I’m kidding of course, for the money, I have no complaints.
One of the things about that SSD, it is a Gen 3 x 2 interface, vs EVOs Gen 3 x 4. As the VIM3 PCIe is a single lane(PCIe 2.0 one lane), I wasn’t sure if the extra benefit of the EVO would be fully realized. And yes, Samsung M.2 NVME drives are pricey, they have a well earned reputation it seems. I use Samsung in my laptops.
The Patriot SSD also works on my Khadas Edge SBCs, those have PCIe 2.1(4 full-duplex lane). There the Samsung drive might matter more.
Up until last night, I have only used the drive to expand storage.
Look forward to your results. I hope they are good, I don’t want you to be mad at me. :grin:

No prob :smiley: . I’ll try.
Some PCIe controller could be quirky handling the memory space, mapping the PCIe address space unproperly in some cases that result in a conflicting memory wrapping. The Orange Pi3 has such problems due to its Allwinner H6 cpu. Hope not the same happening here.

The Patriot SCORCH M.2 SSD 128GB PCIe 3.0x2 NVMe 1.2 SOLVED my problem and as you indicated in your test it does not produce artifacts. It is considerably slower, though, but makes my VIM3 happy!
I think it could be added as candidate in a HW compatibility list. :smiley:
I think as well It could be worth investigate the reasons behind the Sabrent ROCKET 256GB was so problematic.
Thanks ALL.


EDIT: Not even slower, as fast as the other one.

1 Like

I think you are quite right, thanks

Very glad to learn of your results.
Always good to know some less expensive options can be useful.

I agree, however, I am not sure if our sample size, of exactly 2, rises to the level of “Compatibility List” admission. Let’s hope.:smile:

It would be interesting to find the cause of the artifacts when using the Sabrent. It may yet get worked out in subsequent firmware revisions.

Have fun.