Problems with video artifacts using SSD w/Ubuntu 20.04 V0.9-20200530 Initial Release

I’ve trasferred the system to SSD using emmc-install command and everything looks fine, overall responsiveness is now very, very good. Unfortunately there is a problem with the video, similar to a loss of sync in the signal to the 4K display. Is it something I’ve already seen in the Manjaro I’ve tried.The problem gets worse when anything is written to SSD, much less when it is read, although the glitches still there. This problem unfortunately impairs the use of the system significantly.
Using VIM3/PRO


which kernel is this ?

Linux Khadas 5.7.0 #0.9.1 SMP Tue Jun 2 17:07:41 CST 2020 aarch64 aarch64 aarch64 GNU/Linux

I think there were a few patches in that build,

Maybe there are a few problems that need to be addressed that have been solved yet, one could be your SSD problem, because that image the NVMe needs a bit more testing

From another recent thread that at a given point discussed my attempts with the Majaro ARM 20.04 distro (also with kernel 5.7 if I recall it well but not sure) I reported @Spikerguy a problem that looks like very similar, supposedly related to the device tree.

Then you better ask @Spikerguy about Manjaro,

I cannot understand the real issue here.
It’s the the screen flickering issue? Or it is something else.

If it is video playback issue then the playback is done using cpu and not the vpu and I don’t expect vim3 to do 4k on cpu load.

It can only do 4k playback once the vpu drivers are stable and ready to use.

we will test nvme usability later ! in any case u boot still cant start system direct from nvme ! only as usb - ssd

Sorry to create this confusion, no video playback was intended. I attach here below a short movie capture showing the problem. You can note that when the file copy starts the artifacts are produced on the video screen. In the test shown the file is read/written onto the SSD itself, but in normal operation when no SSD activity is involved in the system such problem never occurs. Similar artifacts are shown also with diagnostic messages when booting, in a way that recalled me the same behaviour noted with my Manjaro test (that is why I made a reference to it, perhaps concerning a totally different problem). However, the SD image without mounting the SSD is perfectly fine. System after initial SD installation has been copied to the eMMC (via emmc-install). It does not boot from SSD of course, but from eMMC however with further option of system being transferred to SSD according the relevant emmc-install option, as per its df output:

khadas@Khadas:~$ df -kh
Filesystem Size Used Avail Use% Mounted on
udev 1.5G 0 1.5G 0% /dev
tmpfs 376M 11M 365M 3% /run
/dev/nvme0n1p1 234G 16G 206G 8% /
tmpfs 1.9G 197M 1.7G 11% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup
tmpfs 1.9G 6.4M 1.9G 1% /tmp
/dev/mmcblk2p1 252M 72M 181M 29% /boot
tmpfs 376M 28M 349M 8% /run/user/1000
/dev/mmcblk2p2 29G 17G 11G 61% /media/khadas/bafa2516-319c-4a1e-aede-d50981ae0139

Thank you


If using M2X board, maybe reseat connector. Also insure power supply is delivering required volts and amps.

Seems like a power issue, because with the data you have given, all look like heavy loads, those SSD’s consume a lot of power, I am not sure about peak power draw, but the idle is something like 200mW, so consider your power supply

I dont think its a power issue, I also have been suffering this on my HPZ32 4k monitors… I also have an Odroid N2 and that board also suffered the issue in the early days and if memory serves me correctly it was related the the cpu governor… It was sorted mid last year in an updated image and never gives any issues now. But still stops me using my Khadas Vim 3 annoyingly.

tnx now i can understand what are u talking about :wink: we will check it soon tnx for feedback

Yes, I’m using the M2X board, I’ve tried to reseat it. Power supply is Khadas original. I attach a screenshot with some of the messages from the very first boot stage. As you can note there are some repeated messages pertaining to voltage selection but I’m not sure whether they are really relevant.

I did not get a chance to check this last night. hopefully tonight I will get the time to load that image and test.
Regarding power supply, Khadas offers two types, a 10 watt and a 24 watt PD. While the 10 watt supply is adequate, connected devices can can result in current draws that could create a power starvation issue.
Even if you are using the Khadas 24 watt supply, just to rule it out, if you have a suitable substitute power supply, give it a try.

I will let you know if I experience the issue when I run that image. It will be several hours before I get to the VIM3.

PS is 24W model (FC53). I tried a 5V/3A and the problem appears the same to say the least - indeed my hunch is that with non-original fixed 5V/3A PS the problem even gets worse. Just a little note about the screenshot I attached in my previous post. The complete boot sequence is made of two stages at different display resolution. The photo shown refers to the first stage of these two and in spite of its short duration happens to look stable. Next, the second stage changes to a higher resolution with proper messages coming from the linux kernel outright. It is at this stage the flicker begins to happen.

Thank you

Also, let me add a further observation hoping to give the clearest picture I can.
The vey same equipment (i.e. VIM3/PRO with M2X board and M.2 NVMe) perfectly works with other images kernel 4.9 based and CoreELEC 9.2.2 or LibreELEC that I equally tried - not giving this specific nuisance at all. Hint is that no NVMe utilization is done by these software running.

Hi, pay attention to the multivoltage of the original power supply, I think this is not an accident :slightly_smiling_face:

I did this the first time, but realized I grabbed the 4.9 version. After realizing you were on 5.7, I used the SD 5.7 image.
In both cases, I installed to eMMC/NVMe. Both kernel versions installed without issue. Also in both kernel versions, I noticed no video artifacts when transferring files from USB SD card reader to NVMe or visa versa. The files I transferred were some video files and they played from either location.
Keep in mind, I do not have a 4K display, mine is 1080p.

Thank you for your replies.
The problem is still there even changing resolution to 1080p. I’ve not tried to change the display itself to a 1080p though.
I’ve also tried to exclude the M2X card connecting the M2 SSD directly to the main board but problem also still there. For further reference SSD drive is SABRENT ROCKET NVMEe PCIe M.2 2280 SSD.