Please Make VIM4 boot into OS with DCIN and WOL enabled

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu

Which version of system do you use? Khadas official images, self built images, or others?

Khadas official image

Please describe your issue below:

The system will not boot into Ubuntu when power is applied even though the function is enabled in options.

I have to press the power button or send a magic packet to get it to boot.

What am I missing?

Post a console log of your issue below:

N/A

Do you have an ethernet cable plugged in and does it boot to oowow?

Yes, I use a wired connection.

When I apply power, the LED goes red.

It boots into Ubuntu only when I press the power button or send a magic packet from another device.

Alternatively, I can boot into OOWOW by holding mode and pressing power then releasing them.

can change via oowow main_menu => kbi => DCIN on|off - to normal stage

DCIN has been set to enabled in KBI since I first set up the device but always comes on with a red light and I have to press the power button or send a magic packet to get it to boot into the OS.

As a test, I tried changing it to off, powering off, powering on, setting it to on, powering off and back on but it didn’t help.

Forgot to say that it doesn’t make any difference if I insert an SD card with an OS on it. It still comes on with a red LED and won’t boot until I press power or send a magic packet. Same thing happens if I set it to boot from spi.

I can try resetting the system to defaults if you think it would help.

So, out of desperation, I disabled WOL in the KBI and the system boots into Ubuntu when I apply power.

It seems the options are mutually exclusive.

Is that by design or a bug?

Either way, it means that the system can’t be restarted remotely if it is shut down for any reason.

Can this be escalated to Technical Support please?

When nothing seems to work I always just reset to factory defaults using Krescue/ooWoW then reinstall the image. Keep in mind that you will need to save your important files before starting over again because all will be lost.

Thanks. I could do that but I’d like to know whether this is normal before resetting it as I’ve already reinstalled everything so many times and finally have it configured how I want it.

On the other hand, I don’t see much point in continuing with it if it is normal behaviour.

no need reinstall !!! problem so easy just change KBI/MCU settings via oowow DCIN=on and WOL=off, its will be enough

I really want to enable DCIN and WOL.

Why can’t both be enabled at the same time?

I just checked a VIM4 on a known weak power supply in order to induce boot issues and mine still has a white LED even though it is boot crashing, that still did not generate red. Reconnected to a good power supply and it boots fine white then white heartbeat. All models of the VIMS we have here will start with just power on and boot into OS without button press.

Can you have DCIN and WOL enabled at the same time on a VIM4 and have it boot without pressing any buttons?

Just turned on WOL (red led) and it does require a button press to start boot without LAN sig. Turned it off and it boots with power. I don’t believe it will auto boot when WOL is on because if the power would cycle the device turn on when it should not.

Did you scroll to the bottom and save before booting?

Thanks for your help testing this.

can’t see save anywhere, just Okay but you can’t scroll to it

Are you connected using the linux port and a terminal or hdmi monitor?

keyboard and monitor at the moment

When you click the back button, I believe its on the previous screen before the kbi state in your photo, very bottom option.

nope, sorry, still can’t see save anywhere - just Okay.