pci-E ubuntu server issues (google coral)

Hi guys, one other thing that I like to share (we are working on documenting this):
If you are running a system with kernel version 4.19+ you’ll need to first disable built-in kernel module driver for apex device. It has a known bug which might prevent proper driver update.

  1. Create a blacklist-apex.conf file in /etc/modprobe.d/ with two lines in there:
    blacklist gasket
    blacklist apex

  2. Reboot system

  3. Verify that apex/gasket modules aren’t loaded by doing:
    lsmod|grep apex

  4. Follow steps to install gasket-dkms package from

  1. delete file /etc/modprobe.d/blacklist-apex.conf

  2. reboot system

Then follow other steps from instruction.

Although I’m not sure if this is related to the issue with khadas devices because if lscpi not showing our devices, then it looks like a configuring issue.

1 Like

@namvu I just tried that and made no difference. Based on the specs it should work from the interface point of view. https://coral.withgoogle.com/docs/m2/datasheet/

I had a quick look around and based on the logs it seems to be failing here at func amlogic_pcie_link_up https://github.com/khadas/linux/blob/khadas-vims-4.9.y/drivers/amlogic/pci/pcie-amlogic-v2.c

I tough for a second that coral was not gen 1 or 2 as in the driver but that is not the case. I notices some patches from sept/2019 which haven’t not been applied to pcie-amlogic-v2 (8 month old now) . I am not sure if any of these are relevant but maybe one of them could fix the problem.


I figured it’s not the same issue, if the wrong module were loaded, I’d imagine a runtime issue rather than not being able to detect at all.
So from the source code (thanks for pointing out the)
I believe this is an amlogic phy not linking to the PCIe module. I have no idea if that patch you mentioned would fix this.

Maybe move this to the amlogic forum? :upside_down_face:

Edit: Although that code is on the khadas-vims-4.9.y branch, is this the right build for the vim3 board?

1 Like

Does this different to the NVMe SSD ?

Yes, it the branch used for VIM3.


AFAIK: NVMe is just a protocols for communicating via the PCIe interface. I believe this is an issue to the actual phy chip.

1 Like

No idea yet. If everything is OK, I will get a coral in the end of this month, I hope I can debug with it at that time.

1 Like

Have did you received the coral?

Not yet…I can only get USB version for current stage, M.2 version still need to wait more time…:disappointed_relieved:

I tried to connect a PCI-e sound card through an adapter. Kernel 4.9 produces a similar error in the logs. But on the mainline kernel (5.5 rc2), the sound card was determined. Apparently, you still need to backport the latest changes related to PCI-e.


Any update on this? Did you have a luck to get Coral M2 module to test it out?


1 Like

I just checked, I will try to buy one and feedback here.

I made ubuntu 20.04 image with fenix with mainline linux
uname -a
Linux Khadas 5.6.0
cat /sys/class/mcu/usb_pcie_switch_mode
so it looks like I have pci-e mode

lspci -vvv
is empty and I don’t see any host bridge
and no sign of meson pci-e in dmesg
any idea?

I would like to connect pci-e dvb-t tunner